Help - Macbook Pro pinwheel - ONYX won't launch

Discussion in 'macOS' started by Colin20, Jan 29, 2010.

  1. Colin20 macrumors regular

    Joined:
    Feb 18, 2009
    #1
    Hey guys, I've had my 2.66 MBP for 10 months or so and it has been great but recently I've been getting the pinwheel/beach ball quite often when trying to do simple things such as dragging and dropping several files, changing wallpaper, running iDVD etc. I tried to run Onyx but I get an error saying it can't be launched. I ran the apple disk utility and it hasn't made any difference. I've also used appcleaner to remove Onyx and re-installed it but still no change.

    (OS X 10.5.8)

    I recently ran AppFresh and let it do its thing. So I'm wondering if it messed something up.

    Can anybody help me out here? I don't want to re-install OS X.


    UPDATE: AppFresh installed the Snow Leopard Onyx update so I removed that and installed the correct version. What do I want to do with Onyx?
     
  2. riscy macrumors 6502a

    riscy

    Joined:
    Jan 4, 2008
    Location:
    China
    #2
    Not very helpful, sorry - but this site is fun, and appropriate
     
  3. Colin20 thread starter macrumors regular

    Joined:
    Feb 18, 2009
    #3
    Verified preferences and this is what Onyx said:

    "/Users/colin/Library/Preferences/com.apple.iphotomosaic.plist:
    Conversion of data failed. The file is not UTF-8, or in the encoding specified in XML header if XML."

    What should I do about this?
     
  4. Steenie macrumors newbie

    Joined:
    May 16, 2010
    #4
    Hello, I found this thread in a search and wanted to bump it because I'm having the very same problem, and with the same type of Mac...frequent beachballing, can't get Onyx to even launch, tried the disk utility with no result. Does anyone have an idea about how to fix/handle this?

    Thanks!
     
  5. khankra macrumors newbie

    Joined:
    May 30, 2010
    #5
    Hey, just saw this thread, it looks like you might be trying to download a version of Onyx for Snow Leopard. Go to this link and you will find the correct version for your Mac... hope it works, it did for me.

    http://www.titanium.free.fr/pgs/english/apps.html
     

Share This Page