Help! Macbook Pro wont start...

kingping14

macrumors member
Original poster
Apr 10, 2010
80
0
So I took the notebook apart and upgraded the ram to 8GB this morning, put the cover on (no screws) and the notebook was fine, running smooth. So I turned it off and flipped it around to put the screws back on and afterwards it wont boot!!

I can see nothing on the screen, completely black, when I press the power button the fan HDD lights come on for maybe 5-10 seconds before I hear a loud clicking noise from the HDD (same noise as when you trigger the sudden motion sensor) and everything turns off and it reboots and gets stuck in the same cycle after every click.

What could be the problem here? I was so excited that I've got 8GB ram but now nothing works...

thanks in advance
 

thundersteele

macrumors 68030
Oct 19, 2011
2,984
7
Switzerland
check if the new ram is seated properly. Maybe it was loose, and turning it around to tighten the screws was enough for the RAM to loose contact.

If that doesn't help, put the old ram back in and retry. If that doesn't help... Apple store.
 

kingping14

macrumors member
Original poster
Apr 10, 2010
80
0
check if the new ram is seated properly. Maybe it was loose, and turning it around to tighten the screws was enough for the RAM to loose contact.

If that doesn't help, put the old ram back in and retry. If that doesn't help... Apple store.
tried reseating the new ram and tried old ram too, nothing works...

Dont really want to take it back to the Applestore as I'm out of warranty and will most likely be charged heaps for this.
 

kingping14

macrumors member
Original poster
Apr 10, 2010
80
0
things are working:

Superdrive (took my OSX disc but wont give it back), Power LEDs, fans etc