help MacBook won't boot

Discussion in 'macOS' started by applefan69, May 17, 2008.

  1. applefan69 macrumors 6502a

    applefan69

    Joined:
    Oct 9, 2007
    Location:
    Medicine Hat
    #1
    ok I'm on my iPod touch, (cause by macbook won't boot) so please excise spelling errors, and lack of detail.

    Basically the problem is my MacBook won't boot past the white screen. This is very strange because it had been running 100% fine last night. But this morning I went to boot it and its not working.

    Things I have tried:
    -resetting PRAM
    -booting safe mode
    -booting single user mode
    none of which have worked... So now I'm getting worried.

    My one suspicion would be the app mac pilot I was using it last night.. But I'm quite smart computer-wise and I doubt I would have messed it up. But still I figure if I can just boot up, then I can tell mac pilot to reset to defaults. Please help I'm a long time mac user and for the first time my mac feels like a windows machine. >.<

    FYI I'm running leopard 10.5.2 on a 2.0Ghz intel core 2 duo MacBook.
     
  2. Sweetfeld28 macrumors 65816

    Sweetfeld28

    Joined:
    Feb 10, 2003
    Location:
    Buckeye Country, O-H
    #2
    if you have another mac, with firewire, use target disc mode. See if it can access the drive; then if you need to run disk utility and see if that does anything.

    If not, then i may think your HD may have died. If you have an Apple Store close i might consider taking it there also.
     
  3. aross99 macrumors 68000

    aross99

    Joined:
    Dec 17, 2006
    Location:
    East Lansing, MI
    #3
    You might also try booting off your OS X DVD, and see if it can see your drive.
     
  4. applefan69 thread starter macrumors 6502a

    applefan69

    Joined:
    Oct 9, 2007
    Location:
    Medicine Hat
    #4
    i can still hear my harddrive running/reading data at start up for the first 10 seconds, so idk about my harddrive dying. I might be able to try target disk mode with my parents mac if i can find a firewire cable.


    edit: wth i just tried booting through my start up disk, and well i held C just like im supposed to, after waiting around a minute my apple logo turned into a grey circle with a cross through it, and i dont appear to be able to boot through cd drive.... this sucks my macbook is less then a year old.
     
  5. applefan69 thread starter macrumors 6502a

    applefan69

    Joined:
    Oct 9, 2007
    Location:
    Medicine Hat
    #5
    well i just tried booting in verbose mode, and a line keeps repeating it says something along the lines of 'failed to establish connection with windowServer'

    is that an extremely bad thing? i just booted up on cd. it worked this time for some reason, im repairing permissions as i type.
     
  6. macoazm macrumors newbie

    Joined:
    Sep 8, 2006
    #6
    Help me!!!

    I am having this same exactly issue. And I also blame it on macpilot!! Please.... How did you fixed things up?
     
  7. applefan69 thread starter macrumors 6502a

    applefan69

    Joined:
    Oct 9, 2007
    Location:
    Medicine Hat
    #7
    holy old thread

    ugh reading my old posts reminds me what a n00b i once was :p

    I remember i eventually just did an archive and install cause i never figured a solution. :( sorry for the bad luck
     
  8. macoazm macrumors newbie

    Joined:
    Sep 8, 2006
    #8
    hahah thank you. It was certainly MacPilot's fault... I just repaired the permissions and got my Mac up. Now running 10.5.6.... I was travelling and forgot my installing DVD... but it's okay now.
     

Share This Page