Help! Mass Effect 2 Issue (MacBook Pro 15-inch Early 2011 2.2GHz)

Discussion in 'MacBook Pro' started by Matrinix, Apr 12, 2011.

  1. Matrinix macrumors newbie

    Joined:
    Apr 4, 2011
    Location:
    Florida
    #1
    Hello all,

    When trying to play Mass Effect 2 under Boot Camp with Windows 7 64-bit on my MacBook Pro (15-inch, Early 2011, 2.2GHz), all the text in the menus are smeared and flickering and its impossible to make out what it is saying. Has anyone experienced this and/or know how to fix this problem?

    I am running the stock Boot Camp drivers installed off the Mac OS X disc with the update from Apple Software Update applied. Also, if it helps any, the fans speed up a ton and it almost sounds like a jet engine when this happens.


    Thanks for any and all help,
    Matrinix
     
  2. r3voLoLwuT macrumors member

    Joined:
    Jul 29, 2010
  3. Matrinix thread starter macrumors newbie

    Joined:
    Apr 4, 2011
    Location:
    Florida
    #3
    No, I bought it off Craigslist and it came with the box and everything.
     
  4. MadMac84 macrumors member

    Joined:
    Jul 2, 2007
    #4
    Try these things:

    1. Patch Mass Effect 2 to 1.02
    2. Update Catalyst video drivers to 11.3

    If that doesn't work try reinstalling the game, maybe it got corrupt.

    To fix your fan problem create a new power profile in Win7 and call it something like "Turboboost Disabled." Then customize the profile options to whatever you want, but make sure to set Maximum CPU state to 99%. This will prevent the CPU from overclocking to 3Ghz and will keep it at 2.2Ghz. ME2 doesn't need the extra CPU power even completely maxed out. Your fans should stay much quieter.
     
  5. shot2bits macrumors member

    Joined:
    Mar 1, 2011
    Location:
    United Kingdom
    #5
    That's the standard noise though when the fans kick in to cool the graphics card. I have the same laptop as you..
     

Share This Page