HELP! MBP 320g drive hosed by disconnecting iphone!

Discussion in 'MacBook Pro' started by djtman, Mar 7, 2010.

  1. djtman macrumors newbie

    Joined:
    Oct 28, 2009
    Location:
    Boston, MA
    #1
    I was doing the latest update to my phone, connected to my MBP via itunes. I realized I had to bring get my son from school, so I canceled the update, disconnected the phone, and left. When I came back later and plugged my phone in, all apps were crawling and freezing on me with pinwheels. I restarted the mbp and got the question mark of death. Here are my specs:
    15 inch mbp unibody
    OS 10.5.6
    4G ram
    320g hd
    not sure processor speed but I think 2.5ghz
    (a) I tried to restart with install DVD by pressing C - no change (would not start from disk)
    (b) I reset Pram - no change
    (c) I restarted pressing option - it saw the drive, but would not mount it- no change
    (d) I pulled the drive- hooked it up to a sata connection via usb and started my white MB, the drive did not come up.
    (e) I restarted the white MB again and booted from install disks, it saw the drive, but could not mount it.
    (f) using disk utility did not help, it errored out.
    (e) I ran disk warrior on the drive for A WEEK's time and it told me "speed reduced by disk malfuntion 27,966" before I force quit the app
    MY DELEMA is...I had some video edits on this drive since my last backup that I spent many hours on that I would like to recover. How can I back this drive up, if I can't mount it? I realize that I will probably have to reformat the drive, but I would really like to get this data off. Any suggestions? I have read about the apps "Tech Tools Pro" and "Virtual Lab", but I don't want to spend any more money on things that wont work.
    Any ideas, wisdom would be appreciated.
    PS - I included a pic from when disk warrior was at 16+K
    -Terry
     

    Attached Files:

  2. panzer06 macrumors 68030

    panzer06

    Joined:
    Sep 23, 2006
    Location:
    Kilrath
    #2
    Sounds like a hard disk failure. We used daystar computer in suwanee or Buford Ga to recover our data. It was $55 to diagnose and an addl $55 once they recovered the files.

    As long as it's not doing a bunch of loud clicking they usually can recover it.

    Cheers,
     
  3. djtman thread starter macrumors newbie

    Joined:
    Oct 28, 2009
    Location:
    Boston, MA
    #3
    Hi Panzer,
    Thanks for the reply. It just seems to me that the system files got screwed up with me killing the phone update. I can't believe that it was a hardware failure because of that, but I guess it could happen. Recovering is my last resort, and I have a friend at Iron Mountain that has done some work for me, so I will go that route if I cannot come up with any other solutions.
    How long did the process take with Daystar? That price certainly seems reasonable.
    Thanks again.
    -Terry
     
  4. nephilim7 macrumors regular

    Joined:
    Jun 13, 2008

Share This Page