Help! MBP EFI Firmware Update 2.2 problem!!

Discussion in 'MacBook Pro' started by henkeike, Sep 16, 2011.

  1. henkeike macrumors newbie

    Joined:
    Jul 3, 2011
    #1
    i just did an update, but now after it im no longer able to reach or use my windows 7 on my Boot Camp partition, when i hold down "alt/option" the only thing that comes up is my OS X Lion partition, everything else is gone. the BootCamp HD is "Gone" under my computer too, and when i open boot camp assistant it shows that i can restore my HD to original size, and in Disk Utilities i can see the BOOTCAMP partition, (it's grayed out, no clear text) and it states that the partition size is 112gb, but it can't say how much has been used etc.. and when i run verify or repair i get the following

    Verify and Repair volume “BOOTCAMP”
    Checking file systemChecking Volume /dev/disk0s4...
    Verifying 173056 records ...
    $UpCase file is formatted for use in Windows 7
    Verifying 1 file(s) with EAs...
    Verifying 26015 folders ...
    Deleting entry ".fseventsd" from index 0x5 "."
    Sorting index 0x0 "$SDH" for file "$Secure" (0x9).
    Minor inconsistencies are detected on the volume. 68 files contain incorrect links count
    Recovering 6 orphan files...
    Recovering orphaned file "00000000004dd84b" (0x4b) into directory "501" (0x22)
    Recovering orphaned file "00000000004dd84c" (0x2b9) into directory "501" (0x22)
    Orphan file recovering is completed. Recovered 2 files
    Recovering 4 lost files/directories...
    Created "found.000" folder for lost files
    Volume repair complete.Updating boot support partitions for the volume as required.Error: Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files.

    but with the use of parallels i can start it all and i can acess the partition windows partition with finder, please help me, how can i run my Windows 7 natively with bootcamp without reinstalling and loosing everything
     
  2. jayhawk11 macrumors 6502a

    jayhawk11

    Joined:
    Oct 19, 2007
    #2
    Can you mount the drive in Disk Utility?
     
  3. henkeike thread starter macrumors newbie

    Joined:
    Jul 3, 2011
    #3
    yes, i can unmount and mount it now, and now it also displays the correct info about the drive but i still can boot it :S
     
  4. henkeike thread starter macrumors newbie

    Joined:
    Jul 3, 2011
    #4
    it's like the bootcamp partition is there but can't bee seen or found...
     
  5. psyscott macrumors newbie

    Joined:
    Sep 20, 2011
    #5
    ditto

    I installed the same EFI 2.2 update tonight on a MacBookPro8,3 and now have a similar problem. After installing the update and restarting, I ran Windows 7 Boot Camp using Parallels. It seemed to work, except that the shutdown was very slow. So I restarted in Windows 7 in Parallels and set the Boot Camp to repair on restart. Then I restarted Windows by holding down the option key and selecting the Windows 7 OS. (BTW - There was a new option to select a wireless network, evidently from the update). The computer restarted and it seemed to complete the disk repair. However, as the computer was shutting down after the repair was completed, the screen went black, with an error message that there had been an unauthorized change to Windows, and a note in the corner that Windows was not authentic. I restarted in the Mac OS and was even able to start and run Windows 7 in Parallels without any notice about it being inauthentic, but shutdown was again very slow. Furthermore, now Boot Camp Windows 7 does not appear as a "Startup Disk option". :(
     
  6. psyscott, Sep 21, 2011
    Last edited: Sep 21, 2011

    psyscott macrumors newbie

    Joined:
    Sep 20, 2011
    #6
    Followup -- any news?

    Hi henkeike,

    Since nobody else has replied to this forum thread, it appears that only you and I have encountered this problem with Boot Camp after the EFI 2.2 update. Maybe it's just a coincidence and not related to the update, or somehow related to specifics of our hardware, software, or something that was done subsequently, after installing the update. I previously had a problem with Windows 7 in Boot Camp when it suddenly decided it was a counterfeit copy. However, the symptoms were different; that time it just warned me I was using a counterfeit copy (although it was a University site-licensed copy which had previously been 'certified' as authentic when it was updated.) In that case, it still started in Boot Camp, and the Boot Camp partition was still recognized as having an OS.

    My MacBookPro8,3 has an SSD. Does yours? It's also possible I caused a problem by first opening Windows 7 in Parallels after the EFI update, before I started up Windows 7 by booting directly into Boot Camp. Also note a major difference in our setups; I am running Snow Leopard rather than Lion.

    Have you found a solution yet, or heard reports of similar problems?

    Thanks.
     
  7. jeff33702 macrumors regular

    Joined:
    Jun 2, 2010
    #7
    I have a recent MBP with a HD. I did the update today and while I seem to be able to boot into windows, I get random results when I try to run it from a VM. It frequently blue screens and I have to try 2-3 times before it starts. If I then reboot into windows, it tells me there was a hardware driver error of some kind.
     

Share This Page