Help, MBP Hard Drive is Read-Only, Can't access or unlock any user preferences

Discussion in 'MacBook Pro' started by deaddog, Oct 15, 2011.

  1. deaddog macrumors member

    Joined:
    Aug 20, 2010
    #1
    I could really use some help. I have searched and tried what I could but I am at a loss with what to do. I first noticed this last night when I was trying to switch users and after entering the correct password nothing would happen. I then went to Preferences to reset my password and the lock icon was closed so I clicked to unlock it and it prompted me for my password and after entering the correct one nothing happens. It simply reverts back to the same window without unlocking.

    I am unable to switch users, unlock any locked preferences, install any software, etc as anything that requires my admin password won't work. I am entering the correct password because if the wrong one is entered it "shakes" and the correct one looks as if it will be accepted but it doesn't.

    I have tried running repair in Disk Utility and rebooting multiple times to no avail. I finally decided to try and reinstall Lion however once I get to the page asking for admin allowance it again won't go past the password screen so I can't even do that.

    After reading tons of threads I came across one that pointed to my Macintosh HD. I chose get info and it turns out that I am now Read Only. The only one with write access is System. Therefore I can't do anything.

    I am completely at a loss and really need some help. Some threads I've come across mention running scripts in Terminal but I have no idea what is actually relevant for me and would really prefer some specific help. I was on 10.7.1 so I upgraded to 10.7.2 but the issue is still very much present.

    Any help is greatly appreciated. Thanks.
     
  2. deadwulfe macrumors 6502a

    deadwulfe

    Joined:
    Feb 18, 2010
  3. deaddog thread starter macrumors member

    Joined:
    Aug 20, 2010
    #3
    Yes, it still has me listed as Admin

    (nice name :))
     

Share This Page