Help! MBP screen goes to 256 color mode!!

Discussion in 'MacBook Pro' started by packerfan, Jul 8, 2007.

  1. packerfan macrumors newbie

    Joined:
    Jun 21, 2007
    #1
    I've had my MBP for about 2 weeks now and love it (my first Mac!!). About a week ago, I was poking around the system preferences tab (I don't remember which sub-topic), but all of the sudden my screen and attached monitor went to 256 color mode. I checked the display settings, and it said that both screens were in "millions of colors" mode, and rebooting didn't fix the problem. I figured I would try unplugging the monitor, and, voila, it went back to normal.

    Now, every time I reboot my MBP, it goes to 256 color mode until either:

    1. If the monitor is plugged in, I have to remove and reinsert the DVI cable from the MBP

    2. If it's just the laptop, I have to insert and remove the DVI cable.

    This really sounds like a driver or configuration problem to me, but for the life of me, I can't figure it out. I've tried clearing my PRAM, but that doesn't help either. I figured I would ask for help here before making the trek to the Apple store.

    Any tips are greatly appreciated!!
     
  2. antibact1 macrumors 6502

    Joined:
    Jun 1, 2006
  3. packerfan thread starter macrumors newbie

    Joined:
    Jun 21, 2007
    #3
    Thanks for the reply. I haven't tried a reinstall yet. I kinda want that to be a last resort since I just got everything installed and configured the way I like it.

    The manner in which this problem started really makes me think I checked something by mistake, but I just can't figure out why there would be such a dumb option. I want to say I was in the Universal Access area when this happened.
     
  4. bwawn macrumors member

    Joined:
    Jul 24, 2002
    #4
    There's an "enhance contrast" feature in Universal Access under the "seeing" tab. Change it back to "normal." It's likely set on or near "maximum."
     
  5. antibact1 macrumors 6502

    Joined:
    Jun 1, 2006
    #5
    Unless you're in grayscale mode, there doesn't seem to be anything in Universal Access to indicate a reduced set of colors. If the option in the display settings says millions of colors, either the driver is messed, or you have a hardware failure. Sorry :(
     
  6. antibact1 macrumors 6502

    Joined:
    Jun 1, 2006
    #6
    If that is the issue, it doesn't explain why unplugging the monitor seems to rectify the problem.
     
  7. bwawn macrumors member

    Joined:
    Jul 24, 2002
    #7
    Yes it does.

    Try it out for yourself. Looks like a bug in Universal Access.

    I just plugged in my external monitor, set the contrast to maximum, and then unplugged the monitor. The slider stayed at "maximum" but the screen went back to normal. Still normal when I replugged the monitor too.

    It's the contrast setting doing this to you.
     
  8. packerfan thread starter macrumors newbie

    Joined:
    Jun 21, 2007
    #8
    bwawn,

    That fixed the problem! I thought I had tried that, but obviously not. That definitely seems like a bug in the Universal Access settings.

    Thanks for the help guys!
     
  9. antibact1 macrumors 6502

    Joined:
    Jun 1, 2006
    #9
    Good find. I don't have an external monitor to try this out. Make sure you file a bug report :)
     

Share This Page