Help Me Jailbreak My iPod Touch! :D

Discussion in 'iPod touch Hacks' started by KSR, Jan 15, 2011.

  1. KSR macrumors newbie

    Joined:
    Jan 7, 2011
    #1
    Hello, MacRumors. I come to you today wanting to jailbreak my iPod Touch. I have the 3rd Generation and it is currently running iOS 4.2.1 so "jailbreakme.com" won't work, it says I need a lower version but I don't know how to downgrade. >.>

    Is there another way to jailbreak my iPod Touch? I'm not too techy so, if possible, try to keep it simple and detailed please. Help me. xD
     
  2. Sonny bro macrumors member

    Joined:
    Jan 15, 2011
    #2
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    At this point in time you can only jailbreak using a program called 'redsnow' it is a tethered jailbreak which means every time you turn your ipod off or it runs out of battery you will need the assistance of a computer to reboot it. Quite a nuisance. Using redsnow to jailbreak is a bit technical so your best bet is to wait for a greenpois0n or limera1n jailbreak, these programs are very, very easy to use and will probably take no longer than 5min.
     
  3. KSR, Jan 15, 2011
    Last edited: Jan 15, 2011

    KSR thread starter macrumors newbie

    Joined:
    Jan 7, 2011
    #3
    Is there anyway in knowing when "greenpoisOn" or "limera1n" will come out with their new jailbreaks for 4.2.1? Thank you. :)

    Edit: Is there a way that I can downgrade my iPod Touch far enough to use "jailbreakme.com", or should I wait for greenpoisOn or limera1n? xD
     
  4. tablo13 macrumors 65816

    tablo13

    Joined:
    Jul 29, 2010
    Location:
    Edmonton, Alberta, Canada
    #4
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B118 Safari/6531.22.7)

    Or you can just downgrade to 4.1, comex's untethered jailbreak has been delayed again until 4.2.5 comes out.
     
  5. applemike macrumors 6502

    applemike

    Joined:
    Aug 6, 2008
    #5
    You can downgrade, but only if you have had 4.1 or 4.2 on your iPod before. If not then you cannot downgrade.

    To downgrade, go to google or ant other search engine, and search for iPod touch 3G 4.1 IPSW then download this file to your dektop or a downloads folder.

    go to iTunes and press the shift key (on PC) or the command button (On msc) and press the restore button on your iPod tab on the left.

    Tell it to install the IPSW you have just downloaded. then jailbreak using "Limera1n" or "Greenpois0n". If you need any more help, feel free to reply.
     
  6. Crigger540 macrumors member

    Crigger540

    Joined:
    Jun 16, 2010
    Location:
    The Old Dominion
    #6
    Its not complicated at all and really how often do you reboot or go dead?Tethered is not that bad and its only for a little while until the untethered is out.
     
  7. Synthion macrumors regular

    Joined:
    Jan 4, 2011
    #7
    4.2.1 does not have a stable, or even untethered, jailbreak.
    Follow these steps.

    -Google "iOS 4.1 Ipod Touch 3rd generation IPSW"
    -Download one of the files that pops up
    -Connect your iPod and open iTunes
    -Go to your iPod, hold down Command/shift, (Mac/PC), and select the IPSW you downloaded in step 2
    -Go make a sandwich while you wait
    -Go google redsn0w. (NOT GREENPO1SON, OR LIMERA1N, both are buggy, and incomplete)
    -Download redsn0w
    -when your iPod restore is done, open up redsn0w and follow instructions
    -Voila! A JBiPT! (PS: don't freak out when you see weird machine code on your iPod, it is all part of the process. :D)
     
  8. KSR, Jan 17, 2011
    Last edited: Jan 17, 2011

    KSR thread starter macrumors newbie

    Joined:
    Jan 7, 2011
    #8
    Does the iPod Touch have to be in DFU mode when you restore it this way, through iTunes? :D

    Edit: It states that "the iPod could not be restored because the firmware file is not compatible."... (I was not in DFU mode when I tried this!) Note that my iPod has never been 4.1, I got it at 4.2.1. >.<
     
  9. KSR thread starter macrumors newbie

    Joined:
    Jan 7, 2011
    #9
    So, if I read this right, jailbreakme.com will come out with another jailbreak once the iOS updates get to 4.2.5? I'm new with the iPods so can you possible estimate how long it'll take to get that high? Jailbreakme.com seems like it's the easiest way, as you only have to "Slide to Jailbreak". xD >.>
     

Share This Page