Help me setup IPhone VPN

Discussion in 'Jailbreaks and iOS Hacks' started by d012004, Jul 10, 2007.

  1. d012004 macrumors newbie

    Jul 10, 2007

    I am a Apple fan, bought my iphone on first day iteslf. I had so much expectation about Iphone. Now I am little disappointed that I am not able to connect to my corporate network/outlook using iphone. My company doesn't support IMAP. Other option is connecting thru VPN to my coroprate network. In our company we use Nortel Contivity VPN client(username/password(RSA)) for connecting our corporate network. I tried to configure VPN with PPTP protocal, but I am not able to connect to corporate network. Iphone shows " connecting ..." for very long time and it shows some message(not able to find out what error message is being displayed since it vanishes immediately). My undertstanding is that Nortel VPN client is unversally used, many existing nortel VPN client users would have experienced this issue.Any help on this greatly appreciated
  2. Danrodgers macrumors newbie

    Jul 12, 2007

    I have the same problem (see "VPN won't connect" 7/12/07) and Apple support can't help. I've also had 3 IT people from work mess around with it. I'm left to believe it will require a patch in a future OS upgrade. Let's hope Apple is listening.
  3. Starnamer macrumors newbie

    Jul 4, 2008
    Was a solution found?

    Has anyone managed to get this to work? I have the same problem.
  4. Trebz macrumors member

    Mar 2, 2006
    Same issue here...

    I have dd-wrt vpn set up on my Linksys router. I am using to map back to the router.

    I can connect my XP laptop without any issues. I enter the exact same setting onto the iPhone, and it goes:


    Could not negotiate a connection with the remote PPP server. Please verify your settings and try again."

    Any thoughts?
  5. iphoner2 macrumors newbie

    Jul 17, 2008
    RE: Help me setup IPhone VPN

    I'm totally loving the new iPhone 3g. I waited to get the second generation b/c of the lack of corporate network connectivity. However, after reading extensively about how this was an "Enterprise" phone I was very disappointed to learn about the VPN client shortcomings.

    To those wondering why you can't connect to your corporate network I found out that the iPhone is bundled with the Cisco VPN client which is incompatible with Nortel Networks VPN. I would have hoped that Apple had the foresight to create either a generic VPN client capable of multiple network configurations or multiple VPN clients to choose from. Nortel Networks isn't exactly a small 'winky-dinky' company that no one uses. I would hope Apple could come out with an software upgrade that utilizes both types. Otherwise the term, "Enterprise" enabled become extremely limiting in definition. Well, at least for Apple! Also, I don't know if someone else has found out how, but I also don't see a way for me to access my corporate contact directory. As much as I hated Blackberry's and the Blackjack I & II, they were more "Enterprise" enabled. All said and done, I still love this phone!!!
  6. KDuncan macrumors newbie

    Feb 15, 2008
    Both my iphones (original and 3g) connect my work with pptp vpn. Works fine with no issues. Im the IT guy at work, so i just setup a user and password on the router pptp vpn settings, entered the same settings on my iphones, and they both connected immediately. I also run vnc over the vpn from both phones.

    I havnt tried to setup an IPSEC vpn on it yet. Might try to do that tomorrow if I get a free minute.
  7. Trebz macrumors member

    Mar 2, 2006
    So I gave this another shot and here is what I found.

    If I leave the encryption settings to "Auto" or "Maximum" it does not work. If I switch it to "None" I can connect.

    However, doesn't setting it to none defeat the purpose? Or does the encryption level refer to encrypting the traffic inside of the tunnel (which would already be encrypted)?
  8. schalliol macrumors regular

    May 7, 2002
    Carmel, IN
    Any resolution here? I set up PPTP on DD-WRT and when I try to connect on my iPhone 3G, I get the message "the connection was terminated by the communications device. Please verify your settings and try again."
  9. sjdigital macrumors regular

    Oct 21, 2008
    The Caucasus
    I can confirm Trebz's findings, i.e. that setting Encryption to "None", enables the VPN connection to a Linksys router with dd-wrt.
  10. jwhs75 macrumors newbie

    Jan 9, 2009

    It does not work to connect to Nortel VPN...:confused:. if anyone knows another application please tell me!
  11. cb311 macrumors newbie

    Feb 26, 2008
    by default, for some unknown reason, the encryption is turned off for PPTP in the dd-wrt software. To enable encryption, log into the routers web interface and:

    1. Goto Administration > Commands
    2. Enter "sed -i -e 's/mppe .*/mppe required,stateless/' /tmp/pptpd/options.pptpd"
    3. Save Startup
    4. NOTE: This will force all PPTP clients to use encryption
    5. Save

    Wrapping everything up..

    1. Goto Administration
    2. Reboot Router

    this is taken from the PPTP wiki at:

    This is what I followed to setup PPTP on my iPodtouch to access my home network using ddwrt 24sp1 on a linksys router.
  12. sdsvtdriver macrumors 65816

    Jul 31, 2008
    Southern California
    The IPSec Cisco VPN client on the iPhone is not compatible with the Nortel Contivity VPN server. You have to connect via PPTP, assuming your VPN administrator has enabled this protocol.
  13. Trebz macrumors member

    Mar 2, 2006

    Thanks CB311. Nice to finally have this working.
  14. Gyro Dragona macrumors newbie

    Aug 22, 2007
    I have been trying to get this working for months and can not find a current solution that works. Trying to get this working with my iPod Touch.

    I have been able to get it to connect with encryption turned off on the iPod but after trying this tip it seams to completely break the VPN server to where I can no longer even connect without encryption once removing the change.

    Router: Linksys WRT350N
    Version: DD-WRT v24-sp2 (05/08/09) std-nokaid-usb - build 12060M NEWD Eko
  15. RandomKamikaze macrumors 6502a


    Jan 8, 2009
    :confused: That's the point, as per step 4...
  16. schalliol macrumors regular

    May 7, 2002
    Carmel, IN

    Yeah, can only connect without encryption, though I would love to find a way to do it with encryption.
  17. Gyro Dragona macrumors newbie

    Aug 22, 2007
    That is including once I remove the change from the startup, saving, and then restarting... Any useful information for making it work would by much more appreciated.
  18. Gyro Dragona macrumors newbie

    Aug 22, 2007
    Well, I have gotten to get the VPN server working but I need to change the port used for it to something that can get through the network at the college so I can access my machines at home. So far I have had little luck with doing so.
  19. thep33t macrumors regular

    Jun 18, 2009
    quick clarification, are you trying to access your home computer (outside college network), form inside the college network. Or trying to access home (inside college network), from outside college network?
  20. Gyro Dragona macrumors newbie

    Aug 22, 2007
    Okay, so far I have been able to get it up and running. I can even access my VPN from outside my network (from a friends house using port 1723). The only thing I need now is to get the ports forwarded. As far as I can tell so far the only open ports from inside the college network to the internet are ports 80 (HTTP) and 443 (HTTPS).

    While I am on the college network I am trying to tunnel to my home network to encrypt my data. They block POP3 and IMAP access, i need this to get my mail on my iPod touch.

    I have tried forwarding port 443, it does not work. But I expected that since it is a known thing with DD-WRT that it will not forward ports 80 and 443... Is there a way to force those ports forwarded anyway?

    I plan on posting a comprehensive guide once I get it all working. I have yet to have found a current guide to get it all working in one location.
  21. Gyro Dragona macrumors newbie

    Aug 22, 2007
    Er, so does anybody here know how to force port 443 to forward? It takes more then changing it through the NAT to make it work since DD-WRT uses it, it doesn't forward it properly if done through the interface.

    I need it to be going like this:

    WAN > on internal LAN

    Edit: It looks like I might have it all figured out, I will be testing it today from the college. Hopefully it works. If so I will report it back here.
  22. Gyro Dragona macrumors newbie

    Aug 22, 2007
    Well, I have figured out how to forward port 443 to internal machines (tested working from a friends house) but I have been unable to get it to work with forwarding it to the VPN. I am not sure why that is. But if anybody would like to help me figure it out it would really help. This is the Firewall Script used:

    iptables -t nat -I PREROUTING -p tcp -d $(nvram get wan_ipaddr) --dport 443 -j DNAT --to
    iptables -I FORWARD -p tcp -d --dport 443 -j ACCEPT
    Where "" is the target machine.
  23. jimmy83 macrumors 65816

    Aug 21, 2008
    Portsmouth, UK
    Just curious but why wold you want to use a VPN?
  24. thewitt macrumors 68020


    Sep 13, 2011
    Though this thread is almost two years old, I'll answer your question.

    Many enterprise wireless access points are outside a VPN firewall to help secure the network from intrusion.

    The VPN tunnel allows your device into the rest of the corporate network.

Share This Page