Help me share files with vista and leopard plz

Discussion in 'Mac Basics and Help' started by skasol, Nov 1, 2007.

  1. skasol macrumors 6502

    Joined:
    Sep 20, 2007
    #1
    I have done a search and can't find the answer so I am hoping a kind soul will help me, I have a vista ultimate computer, I also have a mbp and a macbook.
    the 2 macs have leopard and I went to preferences, sharing enabled file sharing and printer sharing and hit advance enable SMB, selected the username and click ok, so here is where it gets tricky.
    I am able to see the vista computer fine, open my shared files on my vista computer write and read fine, my vista computer sees both of my macs but can only drop files in the public shared folder "drop box", it can't open the folder, the same happens between the 2 macs, I am able to see the "drop box folder", and I can drop items there but when I tried to open the folder from another computer it says I don't have enough rights or something like that, eventhough I have enabled read and write for all users, admin, etc. please help.

    I want to be able to share files between the 2 macs as well as my vista computer, vista needs to be able to see files on my mac's drop box as well as the 2 macs to be able to see inside the drop box folder.

    Thank you in advance for your help.

    Art
     
  2. skasol thread starter macrumors 6502

    Joined:
    Sep 20, 2007
  3. Layer3 macrumors newbie

    Joined:
    Oct 25, 2007
    #3
    Vista and Lepord File and Printer Shareing

    Im Havin the same problem... I just want to share a vista printer with my two mac's upstairs.... Can anyone Help... I upgraded hoping to be able to fix this problem but all I'm able to do is see the printer in lepord and it wont let me add it saying I don't have permission.... Please Help us somebody......

    Thanks
     
  4. TBi macrumors 68030

    TBi

    Joined:
    Jul 26, 2005
    Location:
    Ireland
    #4
    Make sure you add read/write access for "Everybody" or else it won't work. You might have to add "Everybody" in specially!
     
  5. biostatman macrumors newbie

    biostatman

    Joined:
    Nov 19, 2007
    #5
    A bizzare solution that works for me

    I problem accessing Leopard files from Vista, specifically, logon to access Leopard shares worked under XP, but not under Vista. Here is the Vista solution I found: Assume my Mac username is frustrated. When logging on to access the Leopard shares under Vista the user name must be literally:

    DOMAIN\frustrated

    Specifically, D-O-M-A-I-N backslash frustrated. NOTE: Capitalization of DOMAIN is essential!

    Why this works when nothing else I tried did is a major mystery. It is simply surreal. How I found this solution was capitalization of DOMAIN in the hint I got from VISTA when I typed the username with an invalid syntax. It took many hours to find this solution, and I am finished fiddling. It would be nice if someone else could find out more about this really weird syntactical solution.

    I am more than a little frustrated because I cannot figure out who to blame.
     
  6. TBi macrumors 68030

    TBi

    Joined:
    Jul 26, 2005
    Location:
    Ireland
    #6
    Probably because the domain name is set as capitals. Anyway why not add "everyone" to the allowed users list and you can then log on as a guest!
     
  7. biostatman macrumors newbie

    biostatman

    Joined:
    Nov 19, 2007
    #7
    Well I never set the anything resembling a domain name on either system. It might be a default. That is why this is so curious.
     
  8. TBi macrumors 68030

    TBi

    Joined:
    Jul 26, 2005
    Location:
    Ireland
    #8
    Windows sets this automatically to "WORKGROUP" or the like. Well it used to in XP.

    Good tip though for those who don't want everyone to see their files!
     
  9. biostatman macrumors newbie

    biostatman

    Joined:
    Nov 19, 2007
    #9
    You are correct the default on the windows side is workgroup (or at least this was the case under XP).

    Also, when I default everything in Leopard it shows up as a member of workgroup when viewed from the Windows side, so Leopard is apparently set up to use the workgroup as the default.

    The issue is that on an XP machine I can logon to Leopard and access the shared files without issues using just a leopard user name, and this is so whether the XP machine is a member of workgroup or some other name. But on the Vista machine the weird syntax as described previously (DOMAIN\username) is required, and this is true whether the VISTA machine is a member of workgroup or some other name.

    The conclusion about naming workgroups in peer-to-peer networking that I had come to even before starting to fiddle with Leopard (my first Mac experience BTW) is that being a member of the same named workgroup has been de-emphasized on the Windows side (if it ever was an issue): I can connect my XP and Vista computers easily whether they are a member of the same named workgroup or not. I am simply warned in the docs that discovery might take a little longer.

    So, where did the DOMAIN token as required when logging on from Vista come from? Is it Leopard requiring this or is it Vista? My suspicion is that it is a Vista thing, but I could easily be convinced otherwise.
     
  10. TBi macrumors 68030

    TBi

    Joined:
    Jul 26, 2005
    Location:
    Ireland
    #10
    I think i read that the DOMAIN thing is part of the enhanced security part of Vista. There is a way to turn it off. If i get a chance i'll look around for where the option is.
     

Share This Page