Help me solve this mystery! Transferring iphoto library.

Discussion in 'Mac Basics and Help' started by emhan98, Oct 27, 2013.

  1. emhan98 macrumors newbie

    Joined:
    Sep 2, 2005
    #1
    Hi everyone, so I've encountered a weird situation. I know this is a long email, but I'm truly confounded and am hoping that one of the extreme geniuses here can help me out. It really is a mystery to me what's going on here...

    I had an older MBP - was stuck on OS 10.5.8, wanted new one, waited for rMBP, happy days. I first got the base $1299 13 incher, took it home, transferred my iphoto library via external HD (copied the library to the drive, then copied the library into my pictures folder on the new rMBP). No problems, I opened iphoto, it said I had to update the library in order for it to work on this new version of iphoto, it did, and great (I think it made HD thumbnails?).

    I came to realize the rMCP wasn't going to be enough HD storage, so I deleted my files and returned it to apple store, got the upper end rMBP. Brought it home, did the exact same thing with iphoto, but this time, when I open iphoto, it doesn't prompt me or anything, but it just opens and says "no photos" in library. But it's definitely assigned to my library (about 43 GB), etc.

    So, I tried to rebuild the library by holding down option-control while opening iphoto, etc. It discovered over 12,000 photos in the library that was not in my database, so it recovered them. Great, except for two things (1) on my old mac, my iphoto says I only have 8,400 photos. So did it recover all my trashed photos too? (2) I lost all my metadata, no albums, events, etc.

    I'd love any thoughts or help -- why didn't the new rMBP prompt me the same way as with the previous new rMBP? How can I recapture the albums? Why does it say 12,000 photos instead of 8,400?
     
  2. igucl macrumors 6502a

    igucl

    Joined:
    Oct 11, 2003
    #2
    You still have the original backup on your external drive, right?

    I would try trashing the library on the Mac and starting over. If you option-click while opening iPhoto, it prompts you to choose the library you want to use. Make sure it is pointed to the correct one.
     
  3. emhan98 thread starter macrumors newbie

    Joined:
    Sep 2, 2005
    #3
    Hi, thanks --

    Yes, I still have the original backup, but I've also tried exactly what you're saying - it's definitely pointed to the right library, but still says "no photos". Weird, right?
     

Share This Page