Help me troubleshoot this Ethernet switch problem

Discussion in 'Mac Basics and Help' started by GanChan, Jun 23, 2017.

  1. GanChan macrumors 6502a

    Joined:
    Jun 21, 2005
    #1
    I just bought a new 5-port NetGear ProSAFE FS105 Ethernet switch. It works just fine with my Mac Mini, but it does NOT work with my Macbook Air through the j5 Create USB 3.0-to-USB adaptor I've always used for that purpose in the past. I get "Status: Connected" with the error message "AX88179 USB 3.0 to Gigabit Ethernet has a self-assigned IP address and will not be able to connect to the Internet." Tried my old Belkin USB adaptor and got a similar message. Tried different ports on the switch; same result.

    So it seems like the switch will ONLY communicate directly to an Ethernet port and won't accept any kind of adaptor? This could be a problem, since I don't have wireless internet at home....

    Network is set to connect using DHCP with passive FTP mode.

    How can I figure this out?
     
  2. Apple fanboy macrumors P6

    Apple fanboy

    Joined:
    Feb 21, 2012
    Location:
    Behind the Lens, UK
    #2
    Did you install a driver for the J5create? They only work with one, not plug and play. That's the very reason we binned the one we had in our boardroom.
     
  3. GanChan, Jun 23, 2017
    Last edited: Jun 23, 2017

    GanChan thread starter macrumors 6502a

    Joined:
    Jun 21, 2005
    #3
    Yeah, the Macbook air has the current driver. It was working with my previous switch.

    Update: Pulled out my old, overheated, half-dead TrendNet switch, and it's communicating to the Air through the j5 Create with no problem. So the failure or incompatibility has to be originating in the NetGear....yes?
     
  4. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #4
    Have you gone into the network settings on your air and checked the settings. Maybe give it a static ip high in the range??
     

Share This Page