Help me understand why I don't see "sent" mail between my ipad, iphone, and imac

Discussion in 'Mac Apps and Mac App Store' started by GhostMac24, Sep 21, 2011.

  1. GhostMac24 macrumors 6502

    GhostMac24

    Joined:
    Jul 27, 2011
    Location:
    NC
    #1
    I'm guessing there is a simple explanation but I don't see it so far.

    My inboxes are all the same (i.e., what is in my inbox is on all 3 devices).

    However, when I send or reply to an email, it is only on the device that was used. This is very frustrating as I send important emails from my iphone and ipad that I need to be able to access on my imac.

    Thanks for any help in advance!

    Cheers.
     
  2. cdcastillo macrumors 6502a

    cdcastillo

    Joined:
    Dec 22, 2007
    Location:
    The cesspit of civilization
    #2
    Because you´re not using IMAP?

    Or maybe it is because the IMAP syncing is not immediate. I see no other reason.
     
  3. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #3
    You'll need to provide more info on your email account to get answers. Is it POP or IMAP? If it's not IMAP then forget it. If it is IMAP who is your provider? Most email providers have specific setup instructions for Apple Mail.
     
  4. M-5 macrumors 65816

    M-5

    Joined:
    Jan 4, 2008
    #4
    I've noticed this as well. I have my Gmail account sent up on my iPhone, iPad, and the mail app on my MacBook Pro.

    All of the messages in my inbox are available on all of my devices, and if I delete a message from one then they'll be deleted when I check on another device. This functions just as I want it to.

    HOWEVER, my "Sent Mail" folder varies between my iPhone and my Mac, for instance. Some messages I sent through the computer are only available on the computer, and some I sent through the iPhone are only available through the iPhone. For some reason some messages are available on both devices.
     
  5. paulsalter macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #5
    Check in mail app on the mac, make sure the preferences are setup to store this information on the server (accounts section)

    check the advanced imap settings on ios device to make sure these are all set to store messages on the server, some of my accounts defaulted to storing these locally on the device
     
  6. GhostMac24, Sep 21, 2011
    Last edited: Sep 21, 2011

    GhostMac24 thread starter macrumors 6502

    GhostMac24

    Joined:
    Jul 27, 2011
    Location:
    NC
    #6
    Sorry guys. Totally forgot to explain my mail account.

    Account is my .mac account and it is IMAP

    On the iMac Mail app I have the box checked to store sent messages on the server.

    On my iPad I have the "sent messages" checked in the "on the server" section not "on my ipad"

    On my iPhone I have it setup the same as the ipad.

    I have attached a screenshot of my iMac, iPad, and iPhone settings.
     

    Attached Files:

  7. paulsalter macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #7
    From looking at these it looks like it could be the mac that is wrong

    from the iPad screen shot, I see you have it set to the server folder, but you also have folders further down for Sent etc using your Mac id

    from you Mac, highlight the folder that is correct for Sent items, go upto the mailbox menu then down to use this mailbox for, and select Sent

    If this is greyed out try it on one of the other sent folders under your mac id

    when one accepts this, copy emails from the other sent folders that are there into this one, then delete these empty sent folders

    try sending a mail and make sure it dosnt ceate a new sent folder and that the mails are doing what you want

    If this works out, then do the same for the Trash, Junk & Drafts folders
     
  8. GhostMac24 thread starter macrumors 6502

    GhostMac24

    Joined:
    Jul 27, 2011
    Location:
    NC
    #8
    paul....thanks for the input!

    Any reason why I have all the folders? I never created them so I am stumped how they are on my iPad (and I also see them on my iMac Mail app).

    For example, on my iMac Mail I have stuff that I am not quite sure why I do as I never set it up that way. I have attached a screenshot of what my iMac Mail app looks like.

    It looks like there is sent mail (with the paper airplane) for each account as well as a sent messages folder under my @mac.com and yet another folder for sent messages for my @mac.com under "on my mac".

    What in the world is going on here??? I'd really like to understand what they all are, how they got there, are they needed, and how to streamline this more efficiently.

    Thanks again for your patience and help! It is very much appreciated :)
     

    Attached Files:

  9. paulsalter, Sep 22, 2011
    Last edited: Sep 22, 2011

    paulsalter macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #9
    I have seen mail do this before (although not creating this many)

    Lets see if we can fix one at a time

    go for Deleted first

    Find all the deleted items folders that are related to mobile Me (server ones showing under me.com) and any 'on my mac' that have your MobileMe name against them

    copy the content of them to the trash mobile me one (the one not expanded near the top where you have inbox/sent etc) and then delete all the ones you just emptied

    you should now just have the one MM deleted items folder/trash

    try deleting an email, does this go to the correct place or create a new folder?

    hope that makes sense so far

    EDIT: if you are not bothered about keeping any deleted msgs, you can delete all deleted mail folders (after the reminders section), then try deleting a mail and see if it creates a new folder or goes where expected
     
  10. GhostMac24 thread starter macrumors 6502

    GhostMac24

    Joined:
    Jul 27, 2011
    Location:
    NC
    #10
    Sweet, thanks! I will work on that a bit later this morning when I break free again. I'll post back my results.

    Thanks so much once again for your input!

    Cheers.
     

Share This Page