Help! Messed up my function key mappings

Discussion in 'Mac Accessories' started by TemeculaMac, Aug 15, 2008.

  1. TemeculaMac macrumors regular

    Joined:
    Aug 8, 2007
    #1
    I managed to somehow screw up my function key mappings, and can't figure out how to get things back to "default".

    I use the following function keys daily:
    F1/F2: brightness
    F3: expose
    F10: mute
    F11: vol down
    F12: vol up

    I somehow hit a key combination that threw everything out of wack. All of my functions have now shifted all over the place (ie: expose is no longer F3, it's now F9).

    I went into system preferences, and was able to re-map expose...but that's it. I can't figure out how to map the audio functions (mute and volume) and brightness control back to their original mappings.

    I tried clicking on "Restore Defaults" within the Keyboard Shortcuts window...but it didn't work.

    Also, I now have an ugly black box around the item I've selected on my desktop. For example, if I click on my hard drive on the desktop...it'll put a big black box around it. If I click (or move my arrow key) on the next item...the black box is then moved there...indicating it's selected. How do I get rid of this ugly box?

    I have NO idea how I screwed this up, but ANY help would be very much appreciated!

    Thanks,
    Gary
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    System Preferences > Keyboard & Mouse > Keyboard > Use all F1, F2, etc. keys as standard function keys.... is that checked?

    Or System Preferences > Universal Access: did you enable?
     
  3. TemeculaMac thread starter macrumors regular

    Joined:
    Aug 8, 2007
    #3
    Dang...you're too fast :D That was it! Now...how did I get this ugly black box to show up?

    Thanks for the fast reply!
     
  4. blodwyn macrumors 65816

    Joined:
    Jul 28, 2004
    Location:
    Portland, Oregon
    #4
    You might have enabled the voiceover assistance, try checking if it's turned on in the Universal Access preference "Seeing" panel. Or try Command-Function-F5 to toggle it.
     
  5. TemeculaMac thread starter macrumors regular

    Joined:
    Aug 8, 2007
    #5
    Crap...now that I turned my volume up, I have an annoying voice telling me everything I'm doing:

    "Opened dialog box, clicked menu, closed window, etc...". It's almost like I enabled everything!
     
  6. TemeculaMac thread starter macrumors regular

    Joined:
    Aug 8, 2007
    #6
    Arggg...you guys are too fast. That was my next problem :) I turned off the annoying voice AND it also got rid of the ugly black box.

    Thanks for all the fast help folks!!!!! It's very much appreciated. :apple:
     
  7. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #7
    System Preferences > Speech > disable these settings
    System Preferences > Universal Access > disable these settings.
     
  8. TemeculaMac thread starter macrumors regular

    Joined:
    Aug 8, 2007
    #8
    You guys rock! Everything is normal again...life can resume.
     
  9. pqotd macrumors newbie

    Joined:
    Apr 26, 2009
    #9
    Function Keys All Messed Up!

    Hi there,

    I was very 'cleverly' trying out all the function keys as I had read that one of them was supposed to be a desktop shortcut i.e when its pressed you see the desktop immediately!

    Somehow all the keys have now all messed up - i.e the volume keys no longer work and instead they produce the dashboard key etc - all very weird for me!

    I've read a similar post by a user who had the same issue last year and have tried to use the reply that was given to him - but its not worked i.e

    System Preferences > Keyboard & Mouse > Keyboard > Use all F1, F2, etc. keys as standard function keys.... (that's checked!)

    I don't know what else to try - why isn't the RESTORE TO FACTORY DEFAULT working! :(

    I know i managed to get the right click mouse button option working for my macbook yesterday (and the F keys seemed to have stopped working since then).

    Pretty please can someone help me :confused: :confused:

    Thanks

    PQOTD
     
  10. Sploich macrumors newbie

    Joined:
    May 4, 2009
    #10
    I've got this exact same problem going on and I have no idea what's wrong. I tried everything suggested thus far in this topic, but nothing has had any effect. Help would be thoroughly appreciated.

    Edit: I fixed it, somehow. I unchecked the "Use all F1, F2, etc. keys" option and it went back to normal.
     

Share This Page