Help. Mojave killed my external monitor.

SCMedic

macrumors regular
Original poster
Feb 8, 2008
186
41
Installed the latest build (which should be near GM for Mojave) and my external monitor is no longer recognized. It's a Dell Ultrawide connected via Displayport (2017 iMac). What gives? Tried the beta Display driver too, no dice.

Any fixes?
 

cch123

macrumors newbie
Mar 17, 2012
5
0
I have a similar issue except it's any monitor plugged into the second Thunderbolt port on my Retina, 15-inch, Mid 2015. I used to use laptop monitor and 2 external monitors connected to thunderbolt ports. Now ony the monitor connected to the first port (the one under the power plug) works.
 

SCMedic

macrumors regular
Original poster
Feb 8, 2008
186
41
I have a similar issue except it's any monitor plugged into the second Thunderbolt port on my Retina, 15-inch, Mid 2015. I used to use laptop monitor and 2 external monitors connected to thunderbolt ports. Now ony the monitor connected to the first port (the one under the power plug) works.
This apparently isn’t isolated to my 2017 iMac. My 2017 MBP retina also gives no display port signal to the external now too. No matter what USB C I use. I guess it’s extremely coincidental that the cable could have gone bad at the exact time I upgraded? Lol

What a headache.
 

soulreaver99

macrumors 68030
Aug 15, 2010
2,876
2,401
Southern California
Works fine on my 2016 MBP connected through USB-C using a 3rd party USB-C hub and Apple's AV adaptor. Have you tried unplugging and plugging back in? My screen went blank after updating and when I did that, everything was fine.

Ran into a similar experience when Sierra just came out and they fixed it after a .1 or .01 update.
 

SCMedic

macrumors regular
Original poster
Feb 8, 2008
186
41
Works fine on my 2016 MBP connected through USB-C using a 3rd party USB-C hub and Apple's AV adaptor. Have you tried unplugging and plugging back in? My screen went blank after updating and when I did that, everything was fine.

Ran into a similar experience when Sierra just came out and they fixed it after a .1 or .01 update.
I've done everything but swap cables. I even ran an HDMI into the external just to make sure it wasn't dead on it's own.

My thinking currently is that the cable went bad, so a new one is coming tomorrow. That just seems really coincidental. Can't think of any reason why Mojave wouldn't support my Dell UltraWide. It's a year old.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.