HELP: MS Word 04 crashing when saving on Intel Mac

Discussion in 'Mac Apps and Mac App Store' started by crassusad44, Aug 11, 2006.

  1. crassusad44 macrumors 6502a

    Nov 30, 2001
    I have a problem with MS Word 2004 crashing when I try to save a document (to any location). The application crashes whenever I try to save, and when I force quit the application my Mac logs me out and quits all other apps. I have reinstalled Office 2004 (after deleting all prefs in ~/Library/Preferences) and updated to Office 11.2.6, but the problem still presists. I'm on a MBP 2GHz with 10.4.7. Somebody else experienced this problem and know how to fix it?
  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    How bizarre. What other apps and/or system hacks are you running at the same time? :)
  3. crassusad44 thread starter macrumors 6502a

    Nov 30, 2001
    Can anyone help? Here is the crash log for Word...

    Translated Code Information:

    Rosetta Version: 14.11
    Args: /Applications/Microsoft Office 2004/Microsoft Word /Applications/Microsoft Office 2004/Microsoft Word -psn_0_1966081
    Exception: EXC_BAD_ACCESS (0x0001)

    Thread 0: (0xb009981c, 0xb80f80af)
    0x90005b9c: /usr/lib/libSystem.B.dylib : _free + 0x5c
    0x0071d204: No symbol
    0x9002bea8: /usr/lib/libSystem.B.dylib : __pthread_body + 0x60
    0x00000000: /System/Library/Frameworks/Carbon.framework/Versions/A/Support/LaunchCFMApp : + 0x0

    PPC Thread State
    srr0: 0x00000000 srr1: 0x00000000 vrsave: 0x00000000
    cr: 0xXXXXXXXX xer: 0x00000000 lr: 0x9000aadc ctr: 0x9000ab80
    r00: 0xffffffe1 r01: 0xf0080ce0 r02: 0x00000001 r03: 0xf0080dcc
    r04: 0x00000102 r05: 0x00000000 r06: 0x00000054 r07: 0x00003503
    r08: 0x000003e8 r09: 0x00000000 r10: 0x00000001 r11: 0xa0006a3c
    r12: 0x9000ab80 r13: 0x00000000 r14: 0x00000000 r15: 0x00000000
    r16: 0x00000000 r17: 0x00000000 r18: 0x00000000 r19: 0x00000000
    r20: 0x00000000 r21: 0x00000000 r22: 0x00000000 r23: 0x00000000
    r24: 0xf0080dcc r25: 0x00000054 r26: 0x00003503 r27: 0x000003e8
    r28: 0x00000000 r29: 0x00000102 r30: 0x00000102 r31: 0x00727fb0

    Thread 1: Crashed (0xb7ffb420, 0xb80f04c4)
    0x90cce378: /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore : _PCFM_MapFile + 0x34
    0x90cce2b4: /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore : _NewFileContainer + 0x94
    0x90cd0840: /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore : _GetNamedContainer + 0x270
    0x90cd61ec: /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore : _PCFragPrepareClosureByName + 0x114
    0x90cd6e80: /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore : _GetSharedLibrary + 0xa8
    0x83beaf04: /Applications/Microsoft Office 2004/Office/Microsoft Office [CFM] : + 0x2df04
    0x83d879ac: /Applications/Microsoft Office 2004/Office/Microsoft Office [CFM] : + 0x1ca9ac
    0x00304da0: No symbol
    0x845eb208: /Applications/Microsoft Office 2004/Microsoft Word [CFM] : + 0x37208
    0x845e956c: /Applications/Microsoft Office 2004/Microsoft Word [CFM] : + 0x3556c
    0x845ceca0: /Applications/Microsoft Office 2004/Microsoft Word [CFM] : + 0x1aca0
    0x845cc324: /Applications/Microsoft Office 2004/Microsoft Word [CFM] : + 0x18324
    0x83bd8464: /Applications/Microsoft Office 2004/Office/Microsoft Office [CFM] : + 0x1b464
    0x845cc078: /Applications/Microsoft Office 2004/Microsoft Word [CFM] : + 0x18078
    0x850b2c00: /Applications/Microsoft Office 2004/Microsoft Word [CFM] : + 0xafec00

    PPC Thread State
    srr0: 0x00000000 srr1: 0x00000000 vrsave: 0x00000000
    cr: 0xXXXXXXXX xer: 0x00000000 lr: 0x90cce3d0 ctr: 0x900c8714
    r00: 0x000000c5 r01: 0xbfffd790 r02: 0x00000000 r03: 0x00000000
    r04: 0x000dfeee r05: 0x00000001 r06: 0x00000002 r07: 0x0000000e
    r08: 0x00000000 r09: 0x00000000 r10: 0x00000006 r11: 0xa0006128
    r12: 0x900c8714 r13: 0x0059b64c r14: 0x0059b618 r15: 0x00000003
    r16: 0xbfffef18 r17: 0x00000000 r18: 0x00000001 r19: 0xa0c760e0
    r20: 0xa0c75210 r21: 0x00000000 r22: 0xa0c7ee30 r23: 0x83db6236
    r24: 0xbfffdc98 r25: 0x00314400 r26: 0x003143c4 r27: 0x003143c0
    r28: 0xbfffd7d8 r29: 0x0000000e r30: 0x00314350 r31: 0x90cce34c
  4. gauchogolfer macrumors 603


    Jan 28, 2005
    American Riviera
    Have you installed the latest Office Security Update, to be sure you're not being affected by a macro virus?
  5. crassusad44 thread starter macrumors 6502a

    Nov 30, 2001
    Problem found... (but not solved)

    The problem seems again to be... yes, Microsoft. It appears that MS Word 2004 has a problem with open type fonts (in my case Adobe Jenson Pro) that makes the application crash on IntelMacs with Tiger. PPC Macs are not affected by this Word bug. The closing of other applications and logging out is a sideeffect of this bug... F*** Microsoft!

    Read more at:

    Seems also like MS actually knows about this very annoying bug, but has as of now done nothing about it:
  6. AarG macrumors newbie

    Aug 20, 2006
    Kill "Save preview picture with this document"

    If you watch Activity Monitor, you'll notice ATSServer going nuts (crashing and re-launching) until it takes everything else with it. What appears to be happening is ATSServer trying to render the text in the Word thumbnail. While this has been identified as an OpenType issue, we've seen it with Type 1 fonts as well.

    If you disable the preview picture in the "Properties" for existing documents, and in "Preferences" so it doesn't get added to new docs, and life should be much happier. For whatever reason, Excel and PowerPoint don't seem to be affected.
  7. crassusad44 thread starter macrumors 6502a

    Nov 30, 2001
    Thanks for the tip. I will try and see if it works. Maybe I will go back to Word. Pages 2 does not really cut it... yet...
  8. GlenR macrumors newbie

    Apr 27, 2005
    Problem solved for me...

    I had the same problem as crassusad44 and AarG's suggestion worked a treat, thanks!

    I've blogged the Problems with Word on an Intel Mac should anyone be intrested.


Share This Page