Help! My backup hardrive won't work

Discussion in 'Mac Basics and Help' started by duranduranie, Jul 3, 2009.

  1. duranduranie macrumors member

    Joined:
    Feb 18, 2009
    #1
    For months it's been acting weird. It stayed on for a day maybe and then just disappeared and I had to keep plugging it in and out but when I tried to open my files it was slow and sometimes crashed my computer. It kept saying "Indexing media" for some reason and messing my computer up.
    Now it won't work at all and says this::

    http://img196.imageshack.us/img196/792/picture1jbm.png


    Does anyone know what went wrong, how or if I can fix it, and if there is any way to restore my files? I know very little about this stuff, so please be as simple as you can, thanks a lot.

    ALSO; I don't have the OS install CD or any other kind of CD for my backup hardrive or Mac, anymore.
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    If it's a backup hard drive, I'm assuming there's nothing on there that you don't have a copy of elsewhere?
     
  3. Nilla macrumors newbie

    Joined:
    Jul 3, 2009
    Location:
    Arizona
    #3
    Is it an external hard drive? Is it formated for your computer? If not go to Utilities>Disk Utility>*select drive*>Erase>*select drop down menu*>Mac OS Extended (journal)
     
  4. MacDawg macrumors P6

    MacDawg

    Joined:
    Mar 20, 2004
    Location:
    "Between the Hedges"
    #4
    At this point, the disk probably just needs to be reformatted as suggested above

    If you have data that needs to be recovered, you can try Disk Warrior or Data Rescue II or File Salvage

    Woof, Woof - Dawg [​IMG]
     

Share This Page