help ? my cydia is just crashing ... cant access?

Discussion in 'Jailbreaks and iOS Hacks' started by sako94, Jul 14, 2009.

  1. sako94 macrumors regular

    Joined:
    May 10, 2008
    #1
    hey guys i need help my cydia keeps crashing and theres no way for it too open like when i click it loads for 1 second then crashes i tried resetting phone and same problem... anyone know a fix w/o restore?
    thanks
     
  2. The General macrumors 601

    Joined:
    Jul 7, 2006
  3. Rapper92c macrumors newbie

    Joined:
    Jul 15, 2009
    #3
    Yeahh Mann same **** here I had 3 upgrades and when it was running it just restarts my itouch and now doesn't open, what are we gunna have to do rejailbreak it ??
     
  4. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #4
    That's... what he said.

    ...

    Dawg.
     
  5. foob macrumors 6502

    foob

    Joined:
    Feb 17, 2009
    #5
    My Cydia was crashing every time it opened. I traced it to corrupt files in /var/lib/dpkg/updates. Deleting them fixed Cydia. I can't guarantee that will fix Cydia crashes but it has worked for several people who have asked the same question here recently.

    Here are a few methods to delete them.

    SSH into the phone and type "rm /var/lib/dpkg/updates/*" (without quotes) and hit enter.

    Open MobileTerminal on the phone and type "rm /var/lib/dpkg/updates/*" (without quotes) and hit enter.

    Use the apps iFile or Discover from Cydia to browse to /var/lib/dpkg/updates/ and swipe the files then select delete, or in iFile select edit, check all the files, then tap the trash can at the bottom.
     
  6. Knowlege Bomb macrumors 601

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #6
    Before going the SSH and delete files route, try going into Cydia and under the manage tab select "Cydia Installer" and reinstall. This has fixed crashing problems for me in the past.
     
  7. loki007420 macrumors member

    Joined:
    Jul 7, 2009
    Location:
    Detroit
    #7
    mine was crashing yesterday but after a reboot it seemed to fix its self..
     

Share This Page