HELP My hard drive turned&walked - Anyone seen it?

Discussion in 'Mac Accessories' started by csf, Feb 27, 2008.

  1. csf macrumors newbie

    Joined:
    Jan 30, 2008
    #1
    I'm freakin out a bit and if anyone can help me I'll love yez.

    My external harddrive got plugged out while tranfering. When I plugged it back in my Mbp said the disk you "inserted cannot be read (Initialize...) (Ignore) (Eject)".

    Not quite knowing what it would do I pressed Initialize.

    The disk still cannot be read(I tried a PC aswell). I've tried 'Data Rescue' no good. I had about 200gb and I'll try anything to get it back. (it feels like my house has been burgled)

    Please help
     
  2. csf thread starter macrumors newbie

    Joined:
    Jan 30, 2008
    #3
    who me?

    Don't post much at all to be honest. Its still all a bit new to me. Is posting the same thing on a few threads a bit of a crime? sorry

    I'm just really worried about all my stuff(everything was on that drive) and the peoples here really seems to know their ****.

    Heres hoping someone can help...
     
  3. csf thread starter macrumors newbie

    Joined:
    Jan 30, 2008
    #4
    Didn't know I wasn't allowed to say **** either!!
     
  4. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #5
    I'd initially posted this to one of the threads you replied to, but makes more sense in this one, so:

    When you say you tried data rescue, do you mean this:

    http://www.prosofteng.com/products/data_rescue.php

    ...if so, and you did the "Thorough Scan" (not just the quick one), and it came up with nothing, I wouldn't hold out much hope of retrieving anything. TechTool Pro also has a system to try and scavenge files off of a corrupted disk, but in my experience if Data Rescue II doesn't find anything, TTP definitely won't either.

    Data Rescue II is free to try, but if you're desperate and it's no good, you might as well pay for a TTP license. At least you can use the rest of its drive maintenance features in the future.

    Drive recovery services are available, but they usually cost several thousand dollars.
     
  5. csf thread starter macrumors newbie

    Joined:
    Jan 30, 2008
    #6
    Cheers for reply

    I used Data Rescue(yah that one) but when i tried to do a thorough scan it wouldn't work, it started off saying "estimated time 750hours" and when I left it for two hours this had gone up to 900 and somtin hours and the satus bar hadn't even moved. Cheers for the advice, will consider tech tools as it literally had everything all my music about 60 films and worst, most my project files. Ah well, spilt milk and all that.

    Hey brand, I just noticed that you posted the same thing on all three threads i posted on, a bit hypocritical, no?(a bit pointless too)
     
  6. RedTomato macrumors 68040

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #7
    I think you just reformatted your HD. In which case everything's gone. :eek:

    Is it still unreadable after initialising?

    Need more details - was it connected via USB or firewire? Was it the data cable or the power cable that got unplugged? How did it happen?

    I suspect the HD got dropped or slammed while it was transferring data, causing a head crash, and basically killing it.
     

Share This Page