help,My iphone 3gs stuck in a white screen

Discussion in 'iPhone Tips, Help and Troubleshooting' started by or100cohen, Mar 20, 2011.

  1. or100cohen macrumors newbie

    Mar 20, 2011
    trying to restore to 4.2.1 with redsn0w
    It's not so worked
    so i get in to redsn0w with tinyumbrella-4.30.03
    and I clicked on Install cydia
    and then it work
    but then isee a bug,whan i traing to turn it up'it dosnt work
    so i get in to redsn0w and then
    "just boot..."
    and it work again
    after 20 m'
    its turn off (i dont keno why)
    so i get in to redsn0w and do "just boot..." **again**
    and its whitescreen.
    my Iphone
    befor i resotre it was 3.1.2
    MC134HB/B - iPhone3GS
  2. Crystal-RX macrumors 68030


    Dec 22, 2008
    Seattle, WA USA
    Your iPhone has 3.1.2. If you want to update your firmware you need to use iTunes. I don't understand about the part you use redsn0w to restore 4.2.1.

    Can you elaborate more on this or tell me what you did so I know what went wrong?
  3. islandboy macrumors newbie

    Mar 20, 2011
    Stuck on white screen

    I'm having the same trouble...stuck on white screen.

    I ran redsn0w on my 3gs 4.2.1 stock firmware (5.15.04) and everything was fine (updated baseband to 06.15.??). Installed cydia to install ultrasn0w. rebooted iphone using redsn0w (tethered jb) and phone worked on T-Mobile.

    Now, just like or100cohen, the phone turned off and I needed to boot tether. it booted right up but after I'd say 10 minutes or so, it turned off again. Tethered boot again and tried to put my wife's sim in iphone and it worked. I went to sleep and found the iphone to be turned off so I tried to tether boot again. Redsn0w does it thing...builds, "press sleep, sleep&home, home button sequence" and it says it done. But I didn't notice the pineapple logo like the boot tethers that I did earlier. It just stays on the white screen.

    Tried to install custom restore but I get errors saying "can't recognize", "server update is unavailable", or error 1600 or 28 pop up. I've tried to restore back into 4.2.1 but unable to. I've tried to run Pwnage 4.2 and 4.1.3 but it says 4.2.1 (3gs) and even the 3.2.2 (ipad) ipsw's are wrong bundle.

    If you have any suggestions, it will be greatly appreciated.:confused::(
  4. JJR51 macrumors newbie

    Jun 22, 2011
    How to fix it

    What you need:

    1.iPhone take apart tools (precision screw driver, suction cup etc)
    2.Windows operating system (Sorry Mac users!)
    3.iTunes 10.1.2 or later
    4.iREB RC3
    5.iPhone 3GS Custom iOS 4.2.1 Firmware (you can also build it yourself with Sn0wbreeze 2.2.1)
    6.GreenPois0n RC6.1
    Warning: Before you proceed, please be warned that dismantling your iPhone will void the warranty and may permanently damage your iPhone. We will not be responsible for any damage caused to your iPhone. You have been warned.


    1.Take apart your iPhone. See YouTube videos here.
    2.Remove the logic board and put it to the side for at least 30 minutes (go have coffee or play your hacked PS3). Separating the logic board from the battery clears the memory that handles the boot process. Note: You can also leave your device uncharged for at least 5 days and will give you similar result.
    3.Now re-assemble your iPhone.
    4.iREB RC3 (right click, Run as Administrator on Windows 7). Go to Recovery Mode Loop Fixer tab and click Set-Auto Boot True.
    5.Go to iREB tab and select 3GS. Your iPhone will be set to pawn DFU mode so that it can accept iPhone 3GS custom iOS 4.2.1 firmware that you just downloaded.
    6.Launch iTunes and press Shift+Restore, then point to the custom IPSW. Restore will begin and wait patiently until it’s finished.
    7.Launch GreenPois0n RC6.1 to untether jailbreak your iPhone (this takes off the hassle of rebooting via Redsn0w after installing ultrasn0w).
    8.Now you can proceed with unlocking your iPhone with ultrasn0w 1.2.

Share This Page