Help my iTunes Library just "reset" itself or something

Discussion in 'Mac Apps and Mac App Store' started by mariokarter, Sep 26, 2008.

  1. mariokarter macrumors member

    Joined:
    Sep 16, 2007
    #1
    I opened iTunes, the full interface didn't pop up, just a tiny little window, similar to the "saving library" one when you shut itunes, it said something about an xml file, and there was an incredibly slow progress bar so to get out I hit the "x" button, it mentioned something about "failed to open" and "didn't repair" and then the program closed. I started itunes again, it only read that I have 7,000 songs (I have 12k) and had to re determine the gapless playback information.

    Has anyone ever had this problem before? I'm betting the xml file is the one that keeps track of my library, and that iTunes failed to read it correctly or something because its broken? if I can fix this please advise, and if not whats the quickest way to completely re add my library from scratch?

    thanks a lot any help would be appreciated.
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #2
    Restore the library XML file from a backup in its last known good state.
     
  3. mariokarter thread starter macrumors member

    Joined:
    Sep 16, 2007
    #3
    take a look at this:
    [​IMG]

    it looks like its the .itl file that is damaged.

    unless itunes made one for me somewhere i dont have a backup of anything.

    i also noted that the columns displayed in itunes reverted to the defaults.


    is there any way i can get itunes to attempt to repair the file and ill just wait it out this time?
     
  4. DaftUnion macrumors 6502a

    DaftUnion

    Joined:
    Feb 22, 2005
    Location:
    Wisconsin
    #4
    It's sad but this has happened to me too (in Windows only). Files somehow seem to get corrupted easier. I've never had a problem in OS X but on Windows XP with me as well, my library has been damaged in the past and I had to have iTunes rebuild the library file for me. Bad thing about this is that you ususally lose all the album art you've tagged on your files through the iTMS in iTunes.

    Usually backing up this file is the best bet from time to time.

    Edit: You're probably out of luck for repairing this file. Might have to rebuild this file, lose album art (tagged with iTunes only) and start over. Always back this file up in the future from time to time.
     
  5. mariokarter thread starter macrumors member

    Joined:
    Sep 16, 2007
    #5
    well what i did was just removed all my music from itunes, and then readded it. worked for a bit but itunes just ****ed itself again today. And considering it takes a good half hour to re set up everything in a fresh itunes im ditching this piece of crap software until it decides to work (ie ill try itunes 9).
     
  6. djwhut99 macrumors newbie

    Joined:
    Sep 23, 2010
    #6
    I never had this problem before until this week. Can anyone tell me whats causing this? :confused:
     

Share This Page