Help?? My login page, my mouse, my keyboard

Discussion in 'OS X Yosemite (10.10)' started by macswitcha2, Feb 27, 2015.

  1. macswitcha2 macrumors 65816

    Joined:
    Oct 18, 2008
    #1
    So yesterday my mouse one click started to act bizar as if it was on second click option. But, preference says it's not. Every time I attempted to click to type or to open an app, the click would go into option menu.

    I shut down to see if that would help but now I can type my login password because all the keys are not working. I press the B key and it backtracks highlighting the previous key.

    And, it's on black and white mode.

    I then login on guest account but the same thing there. My mouse curser is acting bizar and at times looks like a + rather than a regular curser.

    So I log out and when I click on my admin account it automatically starts to log I a password on its own, a very long one, until I force it to stop.


    What can be going on?

    I tried to reset the pram but it never works. It keeps taking me to utilities.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    What kind of mouse is it? If wireless, did you check the batteries?
     
  3. macswitcha2 thread starter macrumors 65816

    Joined:
    Oct 18, 2008
    #3
    The mouse is wireless Magic mouse and keyboard is the longer usb apple keyboard.

    Batteries on the mouse are at 100%.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    What Wi-Fi channel are you using? Are you using 2.4Ghz or 5Ghz?
     
  5. macswitcha2 thread starter macrumors 65816

    Joined:
    Oct 18, 2008
    #5
    Don't know. I would like to know how I would know that.

    However, I found a solution even though i don't know what the cause of the problem was. I got an old usb apple keyboard and everything seems to be working. The mouse bizarre behaivor is a mystery. However, it is working now and all I did was switch the current batteries around from left to right.
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    Hold your Option key down and click on the Wi-Fi icon in the Menu Bar.
     

Share This Page