Help needed, cannot boot up

Discussion in 'OS X Mavericks (10.9)' started by kazakh, Jan 14, 2014.

  1. kazakh, Jan 14, 2014
    Last edited by a moderator: Jan 14, 2014

    kazakh macrumors member

    Joined:
    Jan 19, 2009
    #1
    Hi guys, need your help here please. My macbook pro wouldn't boot up. The screen turn grey but after a few seconds shuts down. When trying to run disk utility - it says that disk must be repaired. When i attempt to repair it, it says that "sinblink link" problem. When I try to use single user mode - I get another error. So, what are my options? Ideally, I would like to delete a folder from terminal and see if i have enough space for fsck -fy method. But I am not familiar with terminal and not sure if thats possible given that the drive would not mount. What else could I do, I do not have recent back up of the drive so I need to mount it somehow. Thanks much.
    Ps. I apologize for the format of this post, i am doing this from my phone and cant figure out how to rotate pictures.

    2

    Last picture
     

    Attached Files:

  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #2
    Looks like drive failure. Reinstall your OSX and restore from backup (Time Machine), preferably after replacing the HDD.
     
  3. kazakh, Jan 14, 2014
    Last edited: Jan 14, 2014

    kazakh thread starter macrumors member

    Joined:
    Jan 19, 2009
    #3
    i hope its not. But I also doubt its a hdd failure. reason is that computer was working fine until about two weeks ago, when i went on vacation. Today I attempted to turn it on with a new charger that I bought. But before doing so, I disconnected the battery and did a Pram and SMC reset. Don't ask why - I read somewhere thats how it should be done for unknown reasons.

    anyways, i really hope that its not hdd failure because computer was off on the table for two weeks with nobody touching it, and it worked before I left for vacation.

    if deleting a folder from terminal is not an option, would i be able to install a copy of lion onto external hdd and boot from it to see if I can mount my hdd from lion? and if yes, is it possible to create a separate partion on my external hdd for installation? i don't want to lose my info on external hdd.
     
  4. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #4
    Hard drives can fail at any time, that's why backups are important. How old is the computer?

    If you have no luck then move the old drive into an external USB enclosure, rebuild the computer and see if you can get any files after you have a working computer.
     
  5. allthingsapple macrumors member

    Joined:
    Dec 27, 2013
    #5
    Also check that the ram inside your Mac is seated properly. I sure hope you have a time machine backup.
     
  6. kazakh thread starter macrumors member

    Joined:
    Jan 19, 2009
    #6
    Well, writing from my computer right now, managed to boot it up.
    Writing this in case someone runs into the same problem as me and it comes up in search. Here is what I ended up doing:
    • Created a bootable flash stick with Lion OS on it. Luckily I had another flash stick from which I installed Lion onto my second flash stick
    • Once I booted from flash stick, I managed to connect my external HDD and get all the info from corrupted internal hard drive
    • Once the information was secure, I decided to play with it and see if I can fix the problem rather than just wiping it clean.
    • I then created another flash stick with DiskWarrior app on it. (Diskwarrior would not start on the flash stick that was running the Lion OS)
    • This app then scanned my internal drive and said that 36% of items on my internal drive were out of order. I have no clue how that happens from laying on the table for two weeks while I am away
    • So I left it running overnight and in the morning came to a message asking me to restructure the drive, which I clicked. After some time it crashed. But when I scanned the drive again, it only showed that less than 1% of my items were out of order. So I guess it fixed most of it overnight. Note that it's hard to tell when the app is working. I spent 4 hours staring at the screen and the progress bar wasn't moving, so I just went to bed.
    • Lastly, once I was able to boot from my regular internal hard drive, I ran a disk verify/repair again from Disk Utility and it fixed some minor problems.
    • That being said, I will now wipe the drive completely clean and do a clean install. But my goal here was to get into my internal drive, get all the information of it. Took me freaking 2 non-stop days copying, rebooting, reloading, rescanning etc.
    • I don't know what caused this, but lack of space (only about 1.1 GB free) on my internal HDD prevented Disk Utility from fixing it right in the beginning. So I had to use a third-party app to fix it.
     

Share This Page