HELP NEEDED: iPhone 3gs stuck in Recovery Loop

Discussion in 'Jailbreaks and iOS Hacks' started by justinhannan, Sep 14, 2011.

  1. justinhannan macrumors newbie

    Sep 14, 2011
    Hey guys,

    I know this is a constant thread problem but I've been researching for days and can't get anything to work.


    1. Phone is stuck in recovery loop due to accidentally clicking 'restore' on itunes forgetting about jail brake.

    2. Cannot even get phone into DFU mode manually using home and power button. When holding the home and power bottom for second time (after doing it initially to turn it off) phone doesn't reset into DFU. Tried multiple techniques.

    3. Tried loading custom firmwares (multiple ones) I get error 1015 also get 20 sometimes and also get 'not available with requested build). Depending on the firmware.

    4. Have Tiny-umbrella and clicked 'exit restore' however it just loads to apple Logo and iTunes doesn't recognise phone.

    5. NoSHSH blobs saved (as it was a accidental stupid restore)

    6. Unsure what IOS I was running prior to accidentally restoring.


    MACBOOK PRO running latest SNOW LEPOAD
    IPHONE 3GS 16gig

    ANY HELP AND I WOULD LORD YOU!!!!!! I don't care about my files or anything, Just want my iPhone working again
  2. Saileshbreaker macrumors regular

    Aug 13, 2011
  3. Crystal-RX macrumors 68030


    Dec 22, 2008
    Seattle, WA USA
    I believe your 3GS has a ipad baseband 06.15 which Itunes did not allow you to restore it to official Apple firmware.

    Try to downgrade it to 4.1 firmware, when Itunes gives you a 1015 error, use tiny umbrella to kick it out of recovery. Use tiny umbrella 4.30.05 version and not the latest one. It works for me but not the latest version.
  4. GlynJones macrumors 6502

    Jun 15, 2005
    That worked for me as well. I used recboot to kick it out of recovery.
  5. justinhannan thread starter macrumors newbie

    Sep 14, 2011
    When I tried to use 4.3.5, I get error 1015. I also tried using libusb + irecovery codes through terminal and still received error 1015.

    When I try to use 4.1 I get error 20.

    I also tried 4.3.5 getting the 1015 error then tried using Tiny Umbrella strait after however, the apple logo comes up for a while, then eventually returns to recovery loop screen.

    Correct, I"m on 6:15:00 baseband.

    Thanks for replying.
  6. bobbytallant, Sep 14, 2011
    Last edited: Sep 14, 2011

    bobbytallant macrumors 6502

    Apr 6, 2010
    I also have an Iphone 3G that is in recovery on 05.15.04 baseband.

    The OS I had it on was 4.2.1.

    Can somebody recommend a good idiots guide to get out of this?
  7. UrBoyTim macrumors member

    Jul 13, 2011
    Yea I experienced the same thing a few days ago with mine.
    I did this and it worked for me.
    You can put it into Pwnd DFU mode via Redsn0w. The only tricky part is starting the process immediately after you turn it off (Because it reboots on it's own). Then restore 4.1 bc you don't need blobs or shsh saved for that. Then kick the sucker out with tinyumbrella after you get the iTunes error.

    ALSO!! Sometimes after you do this process, the phone will appear to be back in recovery after you've "kicked it out with tinyumbrella". It's not; it just appears to be. Just do a hard reboot by holding down the power and home button until apple logo appears. The phone should then go to the emergency call screen.

    My only issue now is that I want to upgrade to 4.3.5 but I can't find a way bc I don't have any blobs or anything lol. Oh well...
  8. ollie101 macrumors newbie

    Sep 14, 2011
    Having the same problem

    Hey guys,
    I'm having the same problem. My jailbroken iPhone 3GS won't come out of recovery mode. I've tried kicking it out with TinyUmbrella, doesn't work...

    When I try to restore it (tried 4.3.5 and 4.3.3 firmware) I get the 1015 error. I am currently on version 4.3.4 firmware.

    I've tried using LibUSB and 'Error 1015 fixer' but to no avail. Nearly managed to destroy my drivers by messing around with LibUSB.

    I'm now downloading firmware version 4.1.0 to see if it will restore to that, but my internet is awful and it's going to take a while to download :(

    I use a Dell Studo 17 running W7 x64 if that helps at all :)
  9. Fantasigraphic macrumors 65816

    Mar 25, 2009
    Put into DFU mode and use FixRecovery. If you get a .dll error GOOGLE the .dll and d/l it and put into same folder (on desktop) with FixRecovery.

    run it and that should kick it out.

    But since you dont have any SHSH saved only option really is 4.3.5.
  10. Peterg2 macrumors 6502a

    Jan 28, 2008
    Montreal, Canada
    I fully endorse Fixrecovery as this was the only one that worked for me. To add to your post regarding a .dll error, it would be easier for the poster to go to Step Ten of this link and obtain zlib1.dll:
  11. ollie101, Sep 15, 2011
    Last edited: Sep 15, 2011

    ollie101 macrumors newbie

    Sep 14, 2011
    I have tried running FixRecovery, that didn't work. Do I need to run it with TSS Server running? Or is it just a matter of entering DFU mode and starting up FixRecovery, then letting it do it's thing? I downloaded zlib1.dll, so I'm not getting that error. I'll try FixRecovery again.

    EDIT: At the end of running FixRecovery 421, or comes up with these worrying lines-

    AND: NAND initialisation failed due to format mismatch or uninitialised NAND. AND: please reboot with reformatting enabled.
    AppleNANDLegacyFIL::start: AND init failed
    Error, no successful firmware download after 60000ms!! Giving up...

    (please note those lines are not a complete section of the log)

    It then fails to do anything, just stays at that black screen with white writing, and I have to reboot it, which returns it to that dreaded "plug into itunes" screen.
  12. ollie101 macrumors newbie

    Sep 14, 2011
    I have 3 SHSH blobs- but I they were saved whilst the iPhone was in recovery loop, so I guess they're useless?
  13. DJBBOX macrumors regular


    Sep 7, 2011
    Miami, FL
    iH8sn0w has a windows program called iFaith that will make a custom ipsw signed with whatever saved shsh blobs you have. you can try that.
  14. ollie101 macrumors newbie

    Sep 14, 2011
    Ok I have found a solution (of sorts)

    I installed firmware 4.1.0 which doesn't need blobs to install. Once I restored using that firmware it gave me a 1015 error but then I just used RecBoot to get it out of recovery mode. Worked fine but now I can't update the firmware without sending it back into the recovery loop.
  15. DJBBOX macrumors regular


    Sep 7, 2011
    Miami, FL
    you might have a old bootrom iPhone 3GS. i can be wrong but i think all devices as of iPhone 3GS(new bootrom) need shsh blobs. you might not need shsh blobs for any firmware.
  16. Crystal-RX macrumors 68030


    Dec 22, 2008
    Seattle, WA USA
    It does not matter if you have old or new bootrom. For some reason, Apple still sign 4.1 for 3GS and it allow us to downgrade 3GS to 4.1. However, because of baseband different, you will get 1015 error. So, just use tiny umbrella to kick it out of recovery at the end and it should bring the phone to normal boot.
  17. bchicago macrumors newbie

    Sep 19, 2011

    I spent 5 hours tearing my hair out trying to figure this out on my 3Gs new bootroom. Your method worked!!!!!!!!!! (downgrading to 4.1 and then using TinyUmbrella)

  18. dlorent macrumors newbie

    Sep 26, 2011

    Guys, I still can't get it to work! I tried both tinyumbrella 4.30.05 as suggested and the latest 5.00 to no avail

    Could you please confirm the steps:
    -Enter Pwned DFU (with redsn0w)
    -Restore to stock 4.1 firmware in iTunes
    -Enter DFU
    -Fix recovery with tinyumbrella

    is it right?

    Also, I can't figure out how to reliably enter DFU from recovery loop - it works one time out of hundred... really annoying... any good suggestions?
  19. kvizzel macrumors 6502a

    Jan 15, 2011
    Finally! Thank you guys so much.

    Just got a iPhone 3GS to fix for my dad. At first I thought it was a regular 3G cause it was stuck in recovery and I couldn't do anything. My brain was like :confused:.

    Downloaded a 3G firmware and confirmed it was 3G

    Downloaded 4.1
    Created Custome with Pwnage
    Enter DFU
    Ta-Da :D

    Thanks guys.
  20. kinaan89 macrumors newbie

    Sep 21, 2011
    Hey there
    My iphone 4 also is stuck in recovery mode
    i cant restore or update i tried ifaith to put the phone in DFU mode then tried restoring to an older firmware or updating both ways it didnt work in the middle after exctracting and restoring it stops and an error message 3194.
    I dont care if my data gets deleted I just want my phone to work.
  21. ollie101 macrumors newbie

    Sep 14, 2011
    You don't need to put it into Pwned DFU (well I didn't anyway) I plugged it in in it's recovery loop state entered regular DFU mode, then just restored to 4.1 through iTunes, then when it finished and gave me the 1015 error I just RecBooted it out of recovery loop.

    You need to hold down the power button and home button for *exactly* 10 seconds, then let go of the power button but continue to hold the home button until iTunes recognises it (about 8 seconds).
    Good Luck!
  22. dlorent macrumors newbie

    Sep 26, 2011
    Thanks for your answer ollie. RecBoot 1.0.2 doesn't help me, phone just restarts and goes back into recovery loop.

    As far as DFU - it's really hard to time it I suppose because I can't switch the phone off - it restarts automatically...

    oh well I guess I just have to buy a new one
  23. dlorent macrumors newbie

    Sep 26, 2011
    I just tried this again and it worked this time!
    No idea why it didn't work before... I haven't even entered DFU this time - just recovered to stock 4.1 IPSW, got error 1015, then ran RecBoot exit recovery and after a restart iPhone loaded successfully
    Thanks for your help guys
  24. sud007, Oct 16, 2011
    Last edited: Oct 16, 2011

    sud007 macrumors newbie

    Sep 29, 2011
    DID u got it working dear?

    hey man I had exactly same problem since last one month, did u get away with it??
    exactly same circumstances u faced, found anything??
    cos every time I try to kick it outta recovery it does nthng...dont know but it seems to be so..
    waitng 4 ur reply..


    @UrBoyTim: Heya, man I had the same preoblem exacltly as 'justinhanan' had, but this is not with me, cos wenever it has to reboot it neva eva goes into recovery loop now (the one with iTUNES logo) it straight away jumps to DFU mode. this has happpened after once i was successfully be able to get it finally into DFU mode with 100s of tries , earler it was stuk in recovery mode loop.

    i dont feel if kicking outta recovery works!
    but yes, i 've been successfully downgraded it to 4.3.3..but stuck in dfu loop :apple:

Share This Page