Help needed!!! iPhone 5S camera not working

pandi.ruvina

macrumors regular
Original poster
Mar 17, 2017
148
42
Hello! i have an iPhone 5S that the rear camera is not working, unable to take photos , remains laggy or freezing, probably i noticed after downgrading from ios 10.3.2 public beta version to ios 10.3.1. The strange thing is that now i'm seeing that on the top of the screen on the right side the display seems to be detached a little bit, maybe from dropping the iphone 2-3 times previously. I just wanted to know if there is any issue related to a swollen battery or is an hardware issue about camera that is needed to be replaced?

I tried all the software steps to troubleshoot the issue, tried to reset settings, restore device as new via iTunes in DFU Mode, but the camera seems to laggy and is not working properly.
Any suggestions on how to proceed, i would really appreciate it!

Thanks in advance
 

Newtons Apple

Suspended
Mar 12, 2014
22,764
14,918
Jacksonville, Florida
Hello! i have an iPhone 5S that the rear camera is not working, unable to take photos , remains laggy or freezing, probably i noticed after downgrading from ios 10.3.2 public beta version to ios 10.3.1. The strange thing is that now i'm seeing that on the top of the screen on the right side the display seems to be detached a little bit, maybe from dropping the iphone 2-3 times previously. I just wanted to know if there is any issue related to a swollen battery or is an hardware issue about camera that is needed to be replaced?

I tried all the software steps to troubleshoot the issue, tried to reset settings, restore device as new via iTunes in DFU Mode, but the camera seems to laggy and is not working properly.
Any suggestions on how to proceed, i would really appreciate it!

Thanks in advance
How much memory do you have available. Lack of memory can cause all kinds of problems.
 

maxjohnson2

macrumors regular
Mar 24, 2017
203
120
If this is caused by the updates, I guess you will have to wait for some new update that might fix the problem. If you're lucky and saved the SHSH blob you could try flashing an older version.
 

pandi.ruvina

macrumors regular
Original poster
Mar 17, 2017
148
42
If this is caused by the updates, I guess you will have to wait for some new update that might fix the problem. If you're lucky and saved the SHSH blob you could try flashing an older version.
I already saved SHSH blob by viewing a guide on YouTube but I just don't know how to restore from. Can you help me please?!

Already runned a diagnostic, doesn't show any hardware issue! When I was on iOS 10.3.2 beta public version this issue didn't persist.
 

pandi.ruvina

macrumors regular
Original poster
Mar 17, 2017
148
42
Not much you can do except restore your phone OS to get rid of the beta OR wait till the next beta update and hope it fixes your problem. Those are about your only choices. Good luck.
The problem started to noticed after downgrading from ios 10.3.2 public beta version to ios 10.3.1! So now i'm at 10.3.1 with camera issue that still persist! I'm so afraid to think that this might be an hardware issue! Already runned a diagnostic, doesn't show any hardware issue! When I was on iOS 10.3.2 beta public version this issue didn't persist.
 

Newtons Apple

Suspended
Mar 12, 2014
22,764
14,918
Jacksonville, Florida
The problem started to noticed after downgrading from ios 10.3.2 public beta version to ios 10.3.1! So now i'm at 10.3.1 with camera issue that still persist! I'm so afraid to think that this might be an hardware issue! Already runned a diagnostic, doesn't show any hardware issue! When I was on iOS 10.3.2 beta public version this issue didn't persist.
You can try re-installing the 10.3.1 to see if that will help. If not is very well could be a hardware problem but I am betting not. If you could get it to the Apple store . . . . . some third party diagnostic apps are not near as good as Apple's.
 

pandi.ruvina

macrumors regular
Original poster
Mar 17, 2017
148
42
You can try re-installing the 10.3.1 to see if that will help. If not is very well could be a hardware problem but I am betting not. If you could get it to the Apple store . . . . . some third party diagnostic apps are not near as good as Apple's.
I tried all the software steps to troubleshoot the issue, tried to reset settings, restore device as new via iTunes in DFU Mode, but the camera seems to laggy and is not working properly! Currently on iOS 10.3.1! The diagnostic was made from apple support, didn't find any hardware issue related to this!
 

MultiFinder17

macrumors 68020
Jan 8, 2008
2,010
708
Tampa, Florida
If you've dropped the phone a few times, the camera may well have worked its way loose. I had the same thing happen to a friend's 5s that I worked on a little while back; she said that the camera wasn't working, and sure enough, the connector had popped loose after a drop. It's worth checking out.
 
  • Like
Reactions: pandi.ruvina

pandi.ruvina

macrumors regular
Original poster
Mar 17, 2017
148
42
why not just reinstall 10.3.2 beta if such issue doesn't exist in beta?
replaced the camera! it was an hardware issue!
[doublepost=1493969660][/doublepost]
If you've dropped the phone a few times, the camera may well have worked its way loose. I had the same thing happen to a friend's 5s that I worked on a little while back; she said that the camera wasn't working, and sure enough, the connector had popped loose after a drop. It's worth checking out.

True! hardware issue because the iPhone was dropped a few times previously! Very Accurate!!