Help needed, iPhone simply refuses to restore

Discussion in 'Jailbreaks and iOS Hacks' started by shiun, Apr 17, 2008.

  1. shiun macrumors newbie

    Joined:
    May 31, 2007
    #1
    Hi,

    Need some help over here.
    My friend's iPhone is bricked and no matter what i try, it simply refuses to restore.
    I jailbreaked, unlocked and activated the 1.1.4 iPhone for my friend using ZiPhone 2.5 back then(2 months back).
    After which the phone was working fine until he started installing tonnes of apps into the phone(my guess is that is what bricked his phone) despite my advise against it as he is a new iPhone user.

    OK here is the situation...
    The iPhone totally does not ON even using the forced restart.
    When the iPhone is plugged into iTunes, it recognizes it in recovery mode and says it must be restored before it can be used. I tried restoring it to 1.0.2/1.1.1/1.1.2/1.1.3/1.1.4 but nothing seems to work and it gives me a couple of different error messages, the most common ones being error 1604.
    During the restoring process, it will go to a WHITE screen then to the Apple logo with the loading icon at the bottom. It will carry on this way until the restore completes and gives and error.

    When plugged in ZiPhone 3.0, it recognizes it being in DFU mode. When i tried change phone mode, be it Recovery mode or Normal mode nothing could be done.
    When plugged in ZiPhone 2.5, i tried the refurbish button but it says that i would need to use iTunes to restore it before i could do anything.

    i have successfully restored quite a number of bricked iPhones over these couple of months but this really stumped me....

    Oh yah 1 more thing, the iPhone totally show no life except during the restore process in iTunes. Other than that, the phone will not ON.

    Hope someone would be able to help me out here.

    Thanks a million~!
     
  2. spinstorm macrumors 65816

    Joined:
    Sep 14, 2007
    #2
    1604 error is relating to the USB ports on your computer.

    Just change USB ports and if that fails change computer and learn how to use google as it will tell you the same thing!
     
  3. polishmacuser macrumors 6502a

    polishmacuser

    Joined:
    Jan 17, 2007
    Location:
    Los Angeles
    #3
    you have tried to put it into dfu mode right by holding the sleep/wake button and home button trick right? if that doesnt work you have a big problem
     
  4. spinstorm macrumors 65816

    Joined:
    Sep 14, 2007
    #4
    Do it on another computer - that will fix it.
     
  5. shiun thread starter macrumors newbie

    Joined:
    May 31, 2007
    #5
    I did google it and switch between multiple Macs(x2) and PCs(x2) before i decided to post and ask for help here.

    Nothing seems to work...
    I have tried holding down the Home and On/Off button for multiple times as well.... sometimes up to 1-2 minutes...
    The thing is, the phone would not even ON itself... so no matter how long i hold the 2 buttons, nothing is happening to the phone or rather nothing visible is happening to it.

    I encountered something like this before but that was via upgrading of 1.0.2 to 1.1.1. Somehow i wan able to get it to work following the steps here:http://code.google.com/p/iphone-elite/wiki/DowngradingBaseband
    However this time round, the phone would not boot up... so i am at a lost...

    any suggestions would be most appreciated~!
     

Share This Page