Help needed with odd MacBook Air problem

Discussion in 'MacBook Air' started by TheDarkEnforcer, Oct 20, 2014.

  1. TheDarkEnforcer macrumors newbie

    Joined:
    Dec 30, 2009
    #1
    Hello,

    I'm hoping that the members of the boards can help me with a problem that my Mom has run into with a MacBook Air she recently bought.

    According to the website everymac.com, my Mother's MacBook is a "MacBook Air "Core 2 Duo" 1.86 13" (Late '10)".

    As we all know, the F9 through F12 keys on this MacBook Air are supposed to perform the following operations when "Use all function keys as standard function keys" is not checked:

    F9=Mute Volume
    F10=Decrease Volume
    F11=Increase Volume
    F12=Eject

    The problem is that, on my mother's computer, the functions for F9-F12 are shifted 1 to the right. On my mother's computer:

    F9=Non Functional (does nothing)
    F10=Mute Volume
    F11=Decrease Volume
    F12=Increase Volume

    My question is that would there be a way to restore the normal functionality to the F9-F12 keys so they act as labeled?

    Also, as a little bit of supporting information, it would appear that the logic board currently in my mother's computer is not the original one. I say this because when TechTool Pro 7 (Version 7.0.4 to be more precise) is launched, under "Check Computer" it says "Built: January 2012". This does not match the information provided by everymac.com.

    Could the newer logic board be causing the problem I've described?

    Thanks to all who respond offering me help with this problem.

    Sincerely,
    TDE
     
  2. brentsg macrumors 68040

    Joined:
    Oct 15, 2008
    #2
    Wrong sub-forum, this is for the Mac Pro desktop.
     
  3. TheDarkEnforcer thread starter macrumors newbie

    Joined:
    Dec 30, 2009
    #3
    Yes, I've just now realized this myself. And I can't delete or lock this either I guess.

    Can a mod please move this to the correct subforum with my apologies?
     
  4. TheDarkEnforcer thread starter macrumors newbie

    Joined:
    Dec 30, 2009
    #4
    Thanks to the Mod who moved this thread to the correct subforum.
     
  5. Lachhh macrumors regular

    Joined:
    Aug 30, 2014
    Location:
    Mainland Europe
    #5
    I'd say yes. The computer might be fetching firmware that isn't right for your 2010 system. Some functions on these keys have changed between 2010 and 2012.
    I'd take it in to a genius and explain the situation. Try an SMC reset first if you haven't done so already.
     
  6. TheDarkEnforcer thread starter macrumors newbie

    Joined:
    Dec 30, 2009
    #6
    Well, for anyone else who wants a crack at it since Lachhh got banned:
    I tried the SMC reset and it did nothing
     
  7. Meister Suspended

    Meister

    Joined:
    Oct 10, 2013
    #7
    Have you tried to reinstall yosemite?
     
  8. TheDarkEnforcer thread starter macrumors newbie

    Joined:
    Dec 30, 2009
    #8
    First off, thanks Meister for taking up where Lachhh left off.

    Secondly, I have not tried an OS re-installation yet, but I doubt that my Mom would be willing to do so until May at the earliest. (The glorious life of a public school teacher, amirite?)

    I'll run it by her and see what she thinks.
     

Share This Page