Help needed with optical digital audio output on iMac

Discussion in 'Digital Audio' started by baseman007, Jan 20, 2009.

  1. baseman007 macrumors newbie

    Joined:
    Jan 20, 2009
    #1
    Hi,

    I am using an iMac connected with a Toslink and an optical cable connected to my audio receiver. Everything worked at first with the volume locking, when the Toslink was inserted. The optical cable still works and I tried changing the Toslink, but I am getting no sound output or any red light. The volume has also stopped locking, when I insert the cable. I am also not getting any option for digital output under Sound in System Preferences or in Audio MIDI Setup in Utilities under Applications.
    Please help me. Any help would be greatly appreciated.

    Thanks in advance from baseman007
     
  2. baseman007 thread starter macrumors newbie

    Joined:
    Jan 20, 2009
    #2
    Please help me. I would also like to add that my analog audio output still works.

    Thanks in advance from baseman007
     
  3. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #3
    I think the physical connector, the jack, on the iMac is not the best quality. Mine will drop a connection of the cable is pulled at just the wrong angle. The problem is getting worse too.

    I think it would be cheaper to buy a USB or Firewire interface then to have the jack replaced because Apple does not fix jacks, they'd replace the entire logic board.
     

Share This Page