HELP new headphones problems

Discussion in 'Mac Accessories' started by Moz430, Dec 25, 2013.

  1. Moz430 macrumors newbie

    Joined:
    Dec 25, 2013
    #1
    Hi everyone my girlfriend has got me some lovely TDK ST600 headphones for christmas as i like to record for youtube.

    Only thing is the USB side of things are not working. my macbook pro is not detecting them through system preferences and audio MIDI setup. The whole reason i asked her for headphones for christmas is so i dont have to piss about with a mixing desk anymore.

    They are plug and play and i can guarantee if i had a pc they would automatically detect and install. This is officially my first real issue with macbook pro.

    Macbook Pro (mid 2009)
    OS X Mavericks
    2.26 GHz Intel Core 2 Duo
    8GB 1067 MHz DDR3
    NVIDIA GeForce 9400M 256 MB
    OS X 10.9.1 (13B42)

    Please Help someone
    Thanks
    Alex
     
  2. durruti macrumors regular

    durruti

    Joined:
    Mar 26, 2004
    Location:
    Jersey
    #2
    Very cool deal.

    However, it's been my experience that it's better to set up some peripheral for Mac OS X that has established support for the device. Otherwise, the result is a lot of time spent on non-guarenteed third party drivers.

    I'd express my gratitude but at the same time I'd look for another device that has native Mac OS X 10.9 support.
     
  3. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #3
    Does TDK provide OS X drivers for them?
    You can also check which USB device do they connect and search for that particular driver.
     

Share This Page