Help - no battery life after upgrade to 2.1

Discussion in 'iPhone Tips, Help and Troubleshooting' started by eaglefam, Sep 22, 2008.

  1. eaglefam macrumors newbie

    Joined:
    Sep 22, 2008
    #1
    Last week when I synced my phone it also upgraded to the 2.1 software. Right after that my battery started to drain quickly. Now it won't ever charge even though it is docked and it says that it is charging. What should I do? Restore my phone to original settings? Help please. It is an original iphone bought last December.

    Many thanks,
    Susan
     
  2. kornyboy macrumors 68000

    Joined:
    Sep 27, 2004
    Location:
    Knoxville, TN (USA)
    #2
    Wirelessly posted (iPhone: Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_1 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5F136 Safari/525.20)

    That is very odd. I'd try a restore and if that doesn't work I'd take it to an Apple Store or call tech support. I think they come with a 1 year warranty so you should be covered.
     
  3. yagrax macrumors regular

    Joined:
    Jul 30, 2007
    #3
    Susan, there is a known bug for some users (not all and not sure why) with the iPhone (original or 3G, doesn't matter) and the 2.1 software upgrade with severe battery drain if you have PUSH turned on for any of your email accounts setup on the iPhone. This has been discussed to death on other forums. There has been official bug reports sent to apple already.

    You can turn off the PUSH or just deal with it until Apple fixes it again (it did not do this under 2.0.2 and previous versions).

    Settings->Fetch New Data-> make 'Push' off.

    Then set your Fetch to something like 30 or 15 minutes.


    Then I'd reboot just to be sure. Then double check that your setting took.


    Good luck.
     
  4. al82 macrumors regular

    Joined:
    Feb 13, 2008
    #4
    You are not alone, my iphone battery has almost HALFED since the update to 2.1 and my iphone is 2 months old.
     
  5. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #5
    Or, she could exchange her phone for one that works fine with 2.1, and not HAVE to wait for the next update.
     
  6. naujoks macrumors 6502

    naujoks

    Joined:
    Jul 6, 2008
    Location:
    London, UK
    #6
    It's the same for me. Previously, at the end of the day, I would have 85% battery left, and now under 2.1 yesterday it was down to 20% and today probably around 30%. Not happy.
     
  7. gray67 macrumors member

    gray67

    Joined:
    Aug 6, 2008
    #7
    I posted a thread about this a couple days ago. The solution is to let your iPhone drain down until it shuts off and then recharge it. Since I've done this, my battery life has improved considerably.
     
  8. yagrax macrumors regular

    Joined:
    Jul 30, 2007
    #8
    That assumes it's hardware. My boss and I have the same issue with our corporate exchange server and severly draining battery. He has 3g and I'm on original iPhone. From the posts I've read (google search will reveal those), it's looking like a situation related issue with particular exchange servers, meaning software itself and/or software configuration. Notice I didn't say which software, iPhone or Exchange, because we don't know yet. The 2.1 could have revealed an issue with certain exchange setups, or 2.1 could have a bug that's not compatible with certain exchange setups, etc, etc, etc.
     
  9. yagrax macrumors regular

    Joined:
    Jul 30, 2007
    #9
    That's YOUR solution, not THE solution. I tried that, didn't work for me.
     
  10. homerjfry macrumors regular

    homerjfry

    Joined:
    Jul 8, 2008
    Location:
    Los Angeles, CA
    #10
    I have the same problem. If I take it back, would a back-up keep all the songs and videos I had on my phone, or would I have to manually place them on my phone again?? This getting annoying, although if I were smart I could have just created an "Iphone" playlist on itunes and drag the entire playlist into my phone and save time. Oh well.

    I think I'll wait a few weeks to see if there is an update, but my battery life was GREAT for about a week and a half and then all of a sudden it is dying like crazy (I watched 20 min of you tube and listened to some songs and then played one hand of poker, which is now crashing everytime I open it, and it was nearly 70% gone already). Argh
     
  11. Kwill macrumors 68000

    Kwill

    Joined:
    Mar 10, 2003
    #11
    Could be a popular app?

    Air Sharing is a popular app that came out shortly after the 2.1 update. What I have noticed is that improper an improper logout can cause battery drain... in addition to Finder freezes.

    Air Sharing (now at 1.0.1) requires a user to 1) start the application on the iPhone, 2) visit the iPhone via Bonjour Wi-Fi. A volume (directory on the iPhone) then mounts on the desktop in which files can be added.

    The application preferences allow the iPhone to sleep after an interval. However, the volume may still appear on the desktop. Sometimes the volume vanishes but communication may still be taking place. The best way to quit is to first unmount the volume on the computer and then quit Air Sharing.

    I have found that somewhere on the network, I may have not properly disconnected this app from one or more host computers. Generally, a fully charged iPhone will remain so overnight. However, if not properly disconnected, an unused iPhone shows minimal battery power remaining overnight. It's a great app. Maybe version 1.0.2 will more cleanly disconnect.

    [EDIT: I have posted this on the Avatron Software Support forum, where it may do the most good.]
     
  12. zebulonx macrumors newbie

    Joined:
    Oct 19, 2008
    #12
    iPhone after 2.1 update

    I don't believe Susan is having the same problem as the rest here. I understand that push is casuing problems with battery holding it's charge as long as it used to, but I believe her problem is exactly like mine. After I updated to 2.1 my iPhone battery also drained all the way down (even while being left plugged in to a powered USB 2.0 port) now it won't charge at all. It just shows a battery symbol on the screen with a little red line on the left side and the charge symbol (or lightning bolt) under it. It can stay like this for days and nothing happens. I can plug it into the wall directly or any other computer or charge device ment for iphone and it still won't charge. It can only be powered down by holding the power button and home button for about 8s, but it won't do anything else. Yes, I can do a restore and have tried everything from 1.1.4 all the way back up (my iPhone is a first generation) I have currently restored it to 2.0, but it still will not charge. Before I did the update, the battery was working perfect and was sitting at 100%, right after the update it dropped to half then very quickly (like about 10 minutes) went to 10% power, then shut off. This is where things get strange. After reading as many posts on the subject as I could find. Most people would say something like "your logic board is fried" or something to that effect, but I sure don't understand how a software update could casue that. Maybe I'm missing something, who knows. Here's what I did ... and I have documented these steps with video I may be posting to utube soon. First I located the disasembly instructions for the iPhone, then after reading it through carefully, I located the proper tools for the job and followed the guide, taking apart my iPhone as instructed (NOT fun), but after very carefully dissasemabling the phone, I was able to remove the battery. I located a battery I had kicking around my house from an old Motorola phone and notice that the voltage was very close to the same as my iPhone (iphone 3.7v and the Motorola was 3.6v ... I figured the lower voltage would be safe and in the worst case, would not boot the iPhone if it didn't meet it's requirments) I wasn't sure about the milliamps, but was willing to take the chance. with nothing to lose. Anyway, I wired up the Motorola battery (already charged) to my iPhone and plugged it in to my iPhone doc. WOW! the iphone came to life and I was able to reload all my apps and settings. I worked perfectly. Another thing that was strange, was that even after using it for a few hours while it was still apart, I put it back into the iPhone doc and noticed that the battery was down a bit, so I left it for an hour or so and it was charging back up. Even more crazy, while my iPhone battery was out of the phone and gave me no reading on the volt meter (dead battery), I put it on the motorola charger and left it to see if it would charge. IT DID! I couldn't believe it. My iPhone battery that would not charge in my iPhone, was charging in my Motorola charger .. and my iPhone WAS charging the Motorola battery WTF! .... I was happy about all this and thinking maybe I had recoverd my iPhone battery from the dead I put i back into my iPhone and put it all back together. Once it was together I was delighted to have it working perfectly again. My iPhone bettery was fully charged from the Motorola charger and I was using it as I had always. Unfortunatly, I'm back to square one now, because once I used up the full charge that the Motorola charger had given me, I dropped my iPhone into the doc and it went from still turning on with 20% battery, to the next moring DEAD with the same screen I wrote about at the begining of the long post ..... and NO I didn't have my computer in sleep mode or turned off. I don't understand, it can't be the battery, because it took a charge from the Motorola charger and it can't be the charge system on the iPhone, because it charged the Motorola battery, so what is the problem when they are connected together?
     

Share This Page