Help - no cellular signal until reboot

Discussion in 'iPhone' started by jugglerAndrew, Jul 18, 2010.

  1. jugglerAndrew macrumors newbie

    Joined:
    Jun 27, 2010
    #1
    Hi,
    Apologies if this has been addressed, I tried a few different search strings and I couldn't find any posts about this.

    Ever since I got my iPhone 4, I've run into this issue twice: The phone will display no bars and no matter where I am I can't get reception. The phone does not receive calls or texts. Both times this happened it was at my house. Depending on where I am in my house I get from about 2 to 4 bars. Basically, if I have low reception I can normally move around and find a decent reception area - not so when this issue happens.

    If I reboot the phone, this fixes the issue. But seeing as this has happened twice, the "fix" isn't quite permanent. Today was the second time the issue happened, so I rebooted the phone and then I also did a settings reset. We'll see if that fixes it.

    (edit) This has happened running both iOS 4.0 and 4.0.1. I am not holding the phone when this starts to happen.
    (edit 2) My carrier is AT&T.

    Has anyone else had this issue? Has a fix been found that keeps this issue from popping up again?

    Cliff notes:
    1) Phone loses cellular reception "permenantly"; can't receive texts or calls.
    2) Only way to "fix" is to reboot the phone.
    3) Want to know if anyone has found a solution that fixes this issue permanently.

    Thanks,
    Andrew


    UPDATE: I got a new SIM card from AT&T. It's been a month since I've ran into the issue so I'm confident that this has been resolved.
     
  2. Daveoc64 macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #2
    I've had this happen to me twice.

    One time I tried sending a text message (with a few bars of signal) and then suddenly the phone dropped to either "No Service" or "Searching" (I can't remember) - even when I went outside.

    I tried toggling Airplane Mode On/Off, but that didn't help.

    Rebooting the phone solved it.

    The second time, I tried to place a phone call (with 5 bars) and it just sat on the call screen for a long time. I tried everything to end the call (the phone really glitched out, with the "Tap to Return to call" bar appearing even though no call was in progress.

    Eventually, the same thing happened as before - "No Service" or "Searching" (forget which), until I rebooted.

    I must admit that I haven't seen it for a few weeks now, or on iOS 4.0.1, but that could just be luck.

    My carrier is O2-UK.
     
  3. smithrh macrumors 68020

    smithrh

    Joined:
    Feb 28, 2009
    #3
    What does the phone display, "searching," or "net search" or just no bars?

    Next time this happens, try a lock and unlock cycle.

    I've potentially had a similar issue but depending on your answers it may not be the same.
     
  4. jugglerAndrew thread starter macrumors newbie

    Joined:
    Jun 27, 2010
    #4
    It shows no bars. Like this: _ _ _ _ _ AT&T
     
  5. smithrh macrumors 68020

    smithrh

    Joined:
    Feb 28, 2009
    #5
    OK, that's not the same issue I had... but it's close.

    Next time this happens, try a lock/unlock cycle to see if that helps.
     
  6. jugglerAndrew thread starter macrumors newbie

    Joined:
    Jun 27, 2010
    #6
    Thanks, I will give that a shot next time. What is your issue? Is it still ongoing for you?

    I think this a pretty serious bug because your phone can behave relatively normal all day while you are still missing calls and texts. You only notice it once you actively try to use your phone (or you notice that the 0 bars never change).

    I'm gonna call Apple and see what they say...
     
  7. smithrh macrumors 68020

    smithrh

    Joined:
    Feb 28, 2009
    #7
    I'd be on a call, be dropped, and the phone would go into "net search" until I unlocked it (it would be locked because I had been on the phone for a long time). I'd see "net search" on my car's BT display.

    Now, I'd get dropped in a lousy signal area, so seeing "net search" made sense, but it remained even after driving into a known good coverage area. Simply unlocking the phone gave me service again.

    This has only happened a couple of times, in fact I've not been able to reproduce it since loading 4.0.1.
     
  8. jugglerAndrew thread starter macrumors newbie

    Joined:
    Jun 27, 2010
    #8
    Just got off the phone with Apple. They suggested a few things they want me to try. Since it's an intermittent issue she didn't want me to go through with all of them at this point, but just start off with the quickest fixes and escalate if necessary.

    Fix 1: Reset Network Settings (Settings > General > Reset> Reset Network Settings)
    I had done a "Reset All Settings," but she told me that was different and to try this first.

    Fix 2: Reset iPhone and setup as new
    That was going to be my next step, so at least support and I are on the same page.

    Fix 3: New SIM card from AT&T

    She had a few other troubleshooting steps but they could only be done if I was experiencing the issue at the moment. I am going to do Fix 1 and see if that resolves the issue. I'll keep everyone updated as I'm sure I can't be the only one with this issue.
     
  9. Mudcrutch macrumors member

    Joined:
    Mar 5, 2008
    #9
    having this exact issue as well. thanks for the tips...
     
  10. jugglerAndrew thread starter macrumors newbie

    Joined:
    Jun 27, 2010
    #10
    Sure! Let me know if you have any luck.

    The issue happened to me again yesterday so I called support back. They had me try fix two. So for me, fix one did not help.
     
  11. BuckyLastard macrumors newbie

    Joined:
    Jun 23, 2010
    #11
    Experienced same issue here two three times , reboot solved it.

    Dont think it has happened again since new fw upgrade
     
  12. SFLamar25 macrumors newbie

    Joined:
    Jul 26, 2010
    #12
    I'm having the same issue except my phone still displays 2 or 3 bars. I'm running 4.0.1 on my iPhone 4. I just reset my network settings today and will monitor to see if it helps.

    jugglerAndrew, did "Fix 2: Reset iPhone and setup as new" seem to work for you?
     
  13. jugglerAndrew thread starter macrumors newbie

    Joined:
    Jun 27, 2010
    #13
    Not sure yet. After I did fix one I didn't see any issues until seven days later. So far so good, but I'm not holding my breath.
     
  14. Daveoc64 macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #14
    My phone is showing "No Service" right now.

    Yet again, I tried sending an SMS and the signal totally dropped out and there's nothing there.

    I've checked the device console using Xcode and I can't see any error message that would explain why the phone wont connect to the network.
     
  15. jugglerAndrew thread starter macrumors newbie

    Joined:
    Jun 27, 2010
    #15
    Fix 2 did not help! The issue happened again just a few hours ago. Now they want me to go to AT&T and get a new SIM card. My support technician also gave me his extension so I can call him direct if the new SIM card doesn't resolve the problem.
     
  16. Insilin1i macrumors regular

    Joined:
    Dec 30, 2009
    Location:
    Toronto, Canada
    #16
    My 3G use to do this often, I set it up as new recently and it stopped. But what I would do was just get a needle or paperclip and pop the sim out and put it back in and it would have signal again. It's a bit easier than restarting the phone and much quicker.
     
  17. bmauter macrumors member

    bmauter

    Joined:
    Sep 3, 2010
    #17
    me too!

    My iPhone4 32GB w/ATT is still doing this, but I've never upgraded to the new iOS. I see no replies here since late July. Does the new firmware correct this?
     
  18. jugglerAndrew thread starter macrumors newbie

    Joined:
    Jun 27, 2010
    #18
    I went to the AT&T store. They set me up with a new SIM card and that solved the issue. It's been over a month and the issue has not popped up so I'm confident that getting the new SIM card solved the problem (its possible that simply re-seating my old SIM card would have worked, but I did not have the patience to try that).
     
  19. rsaffi macrumors newbie

    Joined:
    Feb 3, 2011
    Location:
    Campinas, SP, Brazil
    #19
    I've made an Youtube video showing my problem (exactly the same described by jugglerAndrew). On the video description there are some thoughts about this problem:

    http://www.youtube.com/watch?v=Yf5AUAmQvYU

    Did anyone conclude anything out of this issue? It's really annoying!

    Best regards!

    Saffi
     
  20. ecschwarz macrumors 65816

    ecschwarz

    Joined:
    Jun 28, 2010
    #20
    Mine has done this once or twice, but not to the point that I've had to run to an AT&T store...it also seems to be in weak signal areas where the low signal "sticks" even when I go back to areas that should have 4+ bars.
     

Share This Page