Help on Excel for Mac

Discussion in 'Mac Apps and Mac App Store' started by johnwhite19, Sep 10, 2010.

  1. johnwhite19 macrumors newbie

    Joined:
    Mar 28, 2010
    #1
    I work a lot in Excel for Mac and I have noticed an annoying feature that I can't seem to change. No matter how many times I save a document in "landscape" it keeps on reverting back to "portrait" every time I open it. I have tried to default to landscape but it has not worked. Any ideas? Thanks.
     
  2. sushi Moderator emeritus

    sushi

    Joined:
    Jul 19, 2002
    Location:
    キャンプスワ&#
    #2
    How are you saving to Landscape?

    In other words, what steps are you using to convert your document to Landscape and then saving it?
     
  3. johnwhite19 thread starter macrumors newbie

    Joined:
    Mar 28, 2010
    #3
    Sushi,

    Thanks for your response. I typically go into page setup, hit the landscape button, and press OK. It works then, but when I go into the file a day or so later, it has reverted back to portrait.
     
  4. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #4
    Works fine here. What changes between the time that you save the spreadsheet and when you next open it?
     
  5. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #5
    ...and then, presumably, you Save the file. That should preserve the orientation selection.

    You could try "dumping" the plist file for Excel:
    HD/Users/YourUserName/Library/Preferences/Microsoft/com.microsoft.Excel.prefs.plist

    Move that to your Desktop.
    Go into Excel. This will create a default plist file.
    Test it out and report the result here.
     
  6. sushi Moderator emeritus

    sushi

    Joined:
    Jul 19, 2002
    Location:
    キャンプスワ&#
    #6
    That should work -- assuming that you save the file afterwards.

    Have you tried "SAVE AS..." and giving the file a new name?

    As mentioned below, you might have an issue with your Excel PLIST (Preference) file.

    My suggestion. Try using the "SAVE AS..." command and see what happens. And if that doesn't work, the do what Gregg2 suggests and see if that fixes the issue.

    Please let us know if either idea works. :)

    Also, do yo have this issue in Word or PowerPoint, or just in Excel? And which version are you using 2004 or 2008?
     
  7. johnwhite19 thread starter macrumors newbie

    Joined:
    Mar 28, 2010
    #7
    I have been traveling quite a bit and just got back. It looks like the "Save As" approach is working, although I confess I don't know why. It also seems a bit clumsy to have to be changing the name of the file, but if it works I am all for it.

    I also tried the other approach suggested by Gregg2 but I could not get to the plist. On my computer, after HD/Users/My User Name I did not see anything for "Preferences." The only thing that seemed close was "Microsoft User Data" but that did not seem to go anywhere.

    Anyway, thanks for all your help!
     
  8. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #8
    You skipped one. Look at the path again. You have to go into the Library folder to find Preferences. The "plist shuffle" doesn't always help, but it's harmless to try it. People who really understand the workings of the OS (like programmers, techs, etc.) have better luck, because they will know the exactly what many plist files control. It's worth a try.
     
  9. johnwhite19 thread starter macrumors newbie

    Joined:
    Mar 28, 2010
    #9
    Gregg2,

    You're right--I did miss the Library step. But after the 'Microsoft' step I get an "Office 2008" folder followed by "Excel Toolbars" which does not seem to get me to the plist info you mention. It's probably there somewhere but I haven't been able to locate it. Thanks for your help.
     
  10. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #10
    Actually, as far as I know, it's not in a Microsoft folder, but directly in the Preferences folder. See if that helps.

    jW
     
  11. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #11
    Actually, I have them both inside a Microsoft folder, and just in the Preferences folder. I've moved one from each location and fired up the corresponding program. The one that gets "rebuilt" is inside the Microsoft folder. The path I gave (post #5) is not a typo. I didn't type it. I opened the folder, found the plist file and used drag 'n drop to this window, which produces the full path for me.

    I have that Office 2008 folder as well. (For the life of me, I don't know why. I have O4M 2004!) But the plists files are right there alongside that Office 2008 folder, not buried further "up the tree". However, there might be a difference between 2004 and 2008 as far as where those pesky files are kept. You have, them, guaranteed. What I can't guarantee is that following my suggestion will solve the problem. I'm hoping to learn more about the contents of plist files, so it's just a trial and error idea, kind of like a doctor prescribing medications.
     
  12. johnwhite19 thread starter macrumors newbie

    Joined:
    Mar 28, 2010
    #12
    Well I did find an "Excel plist" in the Preferences folder. I am not sure what to do with it. When I open it all I get is a lot of technical language. I don't see anything clearly that I am supposed to change to fix the problem. Does it sound as if I am looking in the right place?
     
  13. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #13
    The last several times I tried to open a plist file, I just got a TextEdit window that was entirely black (except for the heading). ??
     
  14. johnwhite19 thread starter macrumors newbie

    Joined:
    Mar 28, 2010
    #14
    Gregg2,

    That appears to have worked. I am not sure why dragging it to the desktop would make any difference but apparently it does. I went into a file last night that was portrait, changed it to landscape and saved it. This morning it was still in landscape. In the past, it would have flipped back to portrait.

    Thanks for your help!
     
  15. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #15
    You're welcome! It's not the dragging it to the Desktop that fixes it. That's just the preliminary step that paves the way for the fix. Opening Excel without its plist file in that folder will cause a new plist file to be created. Presumably, since it worked, the one you placed on the Desktop is corrupt. You can now Trash it. The new one it created is set to default preferences. So if you notice some things behaving "the old way" go into Excel preferences and redo your settings.
     

Share This Page