Help on .ipsw custom files // re-jailbreaking iPhone 3G with PwnageTool

Discussion in 'Jailbreaks and iOS Hacks' started by blackout591, Oct 27, 2009.

  1. blackout591 macrumors newbie

    Joined:
    Oct 24, 2009
    #1
    I have an .ipsw file that I've downloaded off the internet, and used that with PwnageTool to create a custom .ipsw file on my iMac OS X.
    So does this mean that when I plug my iPhone 3G (already jailbroken and unlocked, I am running 2.2 with baseband 02.28.00), click (option+restore) and choose the custom .ipsw file, it will restore to that file, and keep my baseband at 02.28.00? I'm just sketchy on doing this because I don't know if the baseband will go up and from what everybody is saying, 5.11.07 is unlockable.

    And since my phone is already jailbroken and unlocked (carrier is T-mobile), Dev team says I do not have to enter DFU mode, so all I would have to do is restore and afterwards just ultrasn0w the link for the unlock?

    btw, 1st time trying to jailbreak by myself, so I'd really appreciate any help.

    p.s.: what's the deal with the 16xx errors that come with these? I've read about some but I don't know exactly what they are and what iReb is and how it coincides with it.

    Thanks!
     
  2. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #2
    First, 5.11.07 isnt unlockable YET. Soon we hope.

    It would be smart for you to update to vanilla 3.0 and start clean. You wont have service, but youll have 4.26.08 BB which IS unlockable.

    THEN, use pwnagetool to create a custom IPSW and upgrade using it. Pwnage tool WILL NOT upgrade your baseband. Once youre on 3.1.2, jailbreak, download ultrasn0w and insert sim.

    16xx errors are errors that come when trying to upgrade to 3.1 / 3.1.2. Theres no real point in using iReb if you dont get 16xx errors on your first install. iReb (google it) is a program which will somehow get around those errors by putting your phone into a special mode when restoring. It works, ive used it.
     
  3. blackout591 thread starter macrumors newbie

    Joined:
    Oct 24, 2009
    #3

    my bad! i was thinking along the lines of "un" as unable, so i meant to say that it isn't unlockable, which is why i am scared to try to jailbreak it if the baseband goes up to 5.11.07.

    Okay, so how would I go about doing that?

    So should I save the current custom .ipsw's that I've already made and do the vanilla 3.0 FIRST, and then update afterwards?

    thanks for all the information about iReb btw! :)
     
  4. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #4
    Heres what I would do.

    1) Download this IPSW (clean 3.0): http://appldnld.apple.com.edgesuite...090617.VfgtU/iPhone1,2_3.0_7A341_Restore.ipsw

    2) Shift + Restore and point to that IPSW. DO NOT HIT RESTORE. HIT SHIFT AND RESTORE!!!!

    3) Once youre on a completely clean 3.0, download resn0w: http://www.quickpwn.com/redsn0w (scroll down)

    4) Jailbreak.

    5) You could unlock on 3.0 if you want just to double check it works, however, if your BB is 4.26.08 youre fine.

    6) Use pwnagetool to create a CUSTOM 3.1.2 IPSW. Update in iTunes doing it however the dev team tells you to.

    7) Double check your BB is 4.26.08 and then reunlock.


    If you get any 16xx errors:

    SHIFT RESTORE to 3.0
    Download iReb
    Do what it says
    Do steps 6 and 7.
     
  5. blackout591 thread starter macrumors newbie

    Joined:
    Oct 24, 2009
    #5

    I am running iTunes and everything on my iMac OS X, so instead of shift, am I supposed to hit Option + Restore to open the organization folder and choose the 3.0 IPSW file you sent me?

    So even if I wanted I could just leave it at 3.0?


    Thanks for the help! I will try this tomorrow and get back to you on my progress.
     
  6. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #6
    Technincally yes. You could stay at 3.0 if you wanted to. If you have no need to organize apps in iTunes you could stay there. And yes, option it is. :)
     
  7. blackout591 thread starter macrumors newbie

    Joined:
    Oct 24, 2009
    #7
    So I successfully jailbroke to 3.1.2 BUT after installing ultrasn0w and saying it was unlocked, my iPhone won't recognize my simcard (t-mobile carrier.) It is at 2.28.08 baseband, I just went straight from my 2.2 to 3.1.2 and it kept that baseband. Any suggestions on what I could do?
     
  8. blackout591 thread starter macrumors newbie

    Joined:
    Oct 24, 2009
    #8
    Actually, it won't even read an AT&T active sim card either, do you know what I could have done wrong after installing ultrasn0w?
    Because before the unlock, the AT&T sim card was working fine with the iPhone.
     
  9. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #9
    Thats very odd. Did you have 3G on during ANY process of the jailbreak? Also, have you rebooted your phone?
     
  10. blackout591 thread starter macrumors newbie

    Joined:
    Oct 24, 2009
    #10
    Nope, 3G was off and I have rebooted several times. I am attempting to remove and reinstall ultrasn0w currently.
    I don't know what's wrong :/


    But oh, I thought 3.1.2 was automatically supposed to come with MMS?
    Is it maybe because I may have downloaded a firmware that didn't include it? Because it doesn't show up on my phone. (the photo icon.)
     
  11. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #11
    Once you install 3.1.2, itunes should have said there was a carrier update available. Go to Settings > general > about and see if your carrier is 5.6.
     
  12. blackout591 thread starter macrumors newbie

    Joined:
    Oct 24, 2009
    #12
    Hmm, I did put in the AT&T sim card after rebooting it the first time and I had clicked "Activate phone" on jailbreaking the iPhone with Pwnage Tool. Could that have caused a problem?

    The phone won't make any calls, even with ultrasn0w removed and with AT&T sim card in. FML.
     
  13. blackout591 thread starter macrumors newbie

    Joined:
    Oct 24, 2009
    #13

    It currently says Carrier AT&T 5.5 :/
     

Share This Page