Help: OS X Lion and Photoshop CS 5

Discussion in 'Design and Graphics' started by rumorsdan, Sep 28, 2016.

  1. rumorsdan macrumors regular

    Joined:
    Mar 1, 2009
    #1
    This is an old problem i'm desperately trying to find an answer for. I have an old mac that I just upgraded to OS X Lion 10.7.5. I've got Photoshop CS5 and I can't save a psd file. Even when starting a new file. I get an "access privileges" error. see pic below.

    It only affects photoshop. Illustrator and Indesign work fine.

    Does anyone know or remember a fix for it?

    photoshop.jpg
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Can you try locate in the Applications folder, right click, 'Get Info'? Add your username to have full privileges?

    Alternatively, try the below. I'm on CS6 but I hope the instructions will be similar:
    1. Open the Adobe Photoshop folder in the Applications folder. There should be an application inside there of the same name. Right-click that application and select 'Show Package Contents'.
    2. Inside 'Contents', there may be a folder called 'MacOS'
    3. Open that folder, and you may see Adobe Photoshop CS5, with a Terminal icon.
    4. Open Terminal seperately and type in chmod 755, then drag that Photoshop CS5 Terminal icon into Terminal.
    5. You'll then see it say 'chmod 755 /Applications\pathetcetc' ... just press Enter

    That should apply a change. Try again?
     
  3. rumorsdan thread starter macrumors regular

    Joined:
    Mar 1, 2009
    #3
    that didn't work.

    which os x are you on?
     
  4. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #5
    El Cap, but the chmod command normally sorts out issues similar to what you described, regardless of OS.

    EDIT:

    Mojo's thread seems to point to the right thing. Copying/pasting the fix below.

    Just to confirm, you can also access the Library that they're talking about by pressing the 'Go' menu in Finder. Then hold Alt and 'Library' should appear. This is different to the Library on Macintosh HD. There are two Libraries on OS X.
    1. Navigate to /Users/YOURUSERNAME/Library/Preferences/Adobe Photoshop CS5 Settings
    2. Select that file File>Get Info
    3. At the very bottom under permissions, hit the + icon.
    4. Add your user name from the list that pops up.
    5. Highlight the user just added.
    6. Click the gear icon to the right of the +/-
    7. Choose make owner.
    8. Click the gear icon again and choose apply to folder contents.
    9. Open Photoshop.
     
  5. rumorsdan thread starter macrumors regular

    Joined:
    Mar 1, 2009
    #6
    In my system, Photoshop CS5 settings is a folder, not a file.
    I added my username as per the instructions, but "make owner" is greyed out.
     
  6. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #7
    Silly question -- are you pressing the 'Lock' icon at the bottom-right, and entering your password, to then make the owner option available?
     
  7. rumorsdan thread starter macrumors regular

    Joined:
    Mar 1, 2009
    #8
    yes.
    Update: it was greyed out because I was already the owner.

    Everything in "save as" will not work. But I can "save for web". This is so annoying. I NEED photoshop.
     
  8. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #9
    Errr... try Permissions Repair in Disk Utilities? Don't verify permissions, just click Repair Disk Permissions. Ensure it's for the OS X volume (the lower/indented of the two Macintosh HD options) rather than the hard-drive itself.

    Once that goes through, restart the computer with 'Reopen windows when logging back in' disabled/unticked. Any luck?

    Is OS X fully up-to-date? 10.7.5?

    Worst case, we can try a nuclear wipe/reinstall of Photoshop. Drag the Photoshop folder from the Applications folder into AppCleaner: https://freemacsoft.net/downloads/AppCleaner_2.3.zip

    Delete everything it finds. Restart again with reopen windows unticked. Try reinstall.
     
  9. rumorsdan, Sep 28, 2016
    Last edited: Sep 28, 2016

    rumorsdan thread starter macrumors regular

    Joined:
    Mar 1, 2009
    #10
    haven't done that yet.
    yes.
    --- Post Merged, Sep 28, 2016 ---
    UPDATE:
    I just had a minor break through. I woke up this morning and thought, what if i connect a separate HD and try to save to that.

    BOOM it works!!!

    So it's got something to do with permissions to the internal HD.
    --- Post Merged, Sep 28, 2016 ---
    Do you mean the HD?

    hd.jpg
     
  10. organicCPU, Sep 29, 2016
    Last edited: Sep 29, 2016

    organicCPU macrumors regular

    organicCPU

    Joined:
    Aug 8, 2016
    #11
    Ideas for writing to the internal HD:
    - Is the version you use Adobe Photoshop 12.0.4? If not update it.
    - Try the permission repair keysofanxiety told you.
    - Did you try to make a new folder in whatever directory you want to write to? This new folder usually gets the needed privileges to write into. If that doesn't work, continue with the following, because your external HD is probably ignoring the ownership. Find out by Get Info... for that external drive and take a look at the lower left.

    - Find out the access privileges for the folder you created on the internal HD in the previous step and for Photoshop:
    Type in Terminal
    Code:
    ls -al /path/to/folder
    You can drag and drop the folder instead of typing the path. Find the line with just a dot (.) in the column on the right. There, in the 1st column the first 4 letters should be "drwx", in the 3rd column should be your username, in the 4th column should be something like wheel, admin or staff.
    Open Photoshop, open Activity Monitor App, in Activity Monitor take a look at the line with Photoshop and compare the Column "User" with the user name of the terminal output.

    - Change owner and group:
    Type in terminal
    Code:
    sudo chown username:group /path/to/folder
    The username is the name you've seen in Activity Monitor's User column. Try wheel for group. Drag and drop the recently new created empty folder for the path to folder. Press enter, enter your admin password, press enter. Try to write again the photoshop file to this folder. If that doesn't work continue.

    - Change access privileges:
    Type in terminal
    Code:
    sudo chmod 700 /path/to/folder
    Drag and drop the same folder for the path. Press enter, enter your admin password, press enter. Try again to write a photoshop file. If that still doesn't work, do the command again, but change 700 to 770, try again to write from photoshop. Still no success, try the command again with 777 instead of 770. If it has something to do with folder permissions on your drive, at some point writing from photoshop should work.
     
  11. rumorsdan thread starter macrumors regular

    Joined:
    Mar 1, 2009
    #12
    Yes. Say's i'm up to date. Will most likely go to CS6 if i can get a copy, but not sure if that will fix it.

    Thanks for the other instructions, Will need to get back to you on that.
     
  12. organicCPU macrumors regular

    organicCPU

    Joined:
    Aug 8, 2016
    #13
    I'm full of curiosity waiting for your response...
     
  13. rumorsdan thread starter macrumors regular

    Joined:
    Mar 1, 2009
    #14
    Repaired permissions and no change.

    Further problem. I can't install any new fonts that Adobe will see. The system can see them but none of the adobe applications load them.
     
  14. organicCPU macrumors regular

    organicCPU

    Joined:
    Aug 8, 2016
    #15
    That's good. Now continue with the step to make a new folder...
    Could be caused by a font cache issue. Booting into safe mode probably won't fix it, but is in your case a good idea anyway -> press SHIFT at startup. That'll wipe the system font cache, too. After that just reboot as usual. The easiest solution to wipe all font caches, including the Adobe specific ones, is FontNuke.
     

Share This Page