Help! OSX won't boot after installing Ubuntu

Discussion in 'macOS' started by epsilon707, Aug 20, 2012.

  1. epsilon707 macrumors newbie

    Joined:
    Jul 21, 2011
    #1
    I'm sure most of you will laugh at my story, but I wasn't the smartest tool in the shed here. I tried installing Ubuntu following a guide that said to use rEFIt. I'm running OSX 10.8 on MBP 8,1 (Or atleast I was).

    Unfortunately rEFIt didn't pickup on my 12.04 disc that I burned when I put it in. :(

    So, I went to the menu that you access by holding down option while booting up (Dawrin?). Anyways I got to that and two discs popped up. One labeled Windows and the Other was "EFI Boot", I believe. I remember it had "EFI". Anyways, I did this and got into ubuntu, and it worked great.

    Until, I realized the wifi didn't have a driver, so I went to boot back into OSX, upon restarting GRUB came up in purple. I tried booting into x64 OSX, but my screen turned black and the computer beeped 3 times in a row, paused, then again and again. This happened until I forced shutdown.

    So OSX (Darwin?) won't boot up :( If you guys know how I could fix this without wiping my harddrive, I'd be VERY VERY VERY thankful

    Thanks in advance :confused:
     
  2. stchman macrumors 6502a

    Joined:
    Jul 16, 2012
    Location:
    St. Louis, MO
    #2
    If I am not mistaken, you were supposed to use BootCamp to create space for Ubuntu. After that OS X is the boot manager and not GRUB.
     

Share This Page