Help playing NES style RPG on mac

Discussion in 'Mac and PC Games' started by Chilaha, Jul 1, 2012.

  1. Chilaha macrumors member

    Joined:
    Jun 26, 2011
    #1
    Can anyone help me play this game on my macbook? I was luckily able to download all the files without them saying I needed to go to parallels. But, I can't seem to get the game out of the exe format. I tried compressing and I'm not sure if I did it properly.
    And, my mac prompts me asking what I want to open the game with. Just wondering if there is any program I need to open it with?
    Thanks,
    Chilaha

    Game is called The Antagonist
    HERE IS LINK TO GAME: http://www.therebelplanet.com/free-games/233.html
    Chilaha
     
  2. doh123, Jul 1, 2012
    Last edited: Jul 1, 2012

    doh123 macrumors 65816

    Joined:
    Dec 28, 2009
    #2
    Sadly thats a Windows only game.

    I tested it out really quick with Wineskin and got it to work on my machine.

    I'll give you a copy since this is free software anyways... but it only works right running it in a window, so no going fullscreen.

    The controls are listed as...
    Arrow Keys = really should be intuitive
    Space/Enter/Ctrl = confirm
    Alt = cancel (also brings up menu in walkabout mode)
    Esc = hold to run from battles
    Pause/Break = pauses in mid-battle (I don't think you can do this on on your Mac)

    Can download it here..
    https://dl.dropbox.com/u/4486028/Antagonist.app.zip
    Just double click to unzip, then put the app in your Applications folder or wherever you want it and it should work. (you can get rid of the zip file)
    I played it very little so I do not know if there are any bugs or problems, or if it will even run on your machine.

    EDIT: found a little bug that caused it not to start up right sometimes, so if you downloaded it and it doesn't start, delete it and download it again and the newer one should work.
     
  3. Chilaha thread starter macrumors member

    Joined:
    Jun 26, 2011
    #3
    Thank you so much for making a port for me. I appreciate it a lot. Now, there is only one problem left. I am using OSX version 10.5.8 and it is telling me that this version is too old to run that application. Do you know what to do?
    I also downloaded it twice.
    Thanks,
    Chilaha
     
  4. doh123 macrumors 65816

    Joined:
    Dec 28, 2009
    #4
    you're still on 10.5? uhhhgg.. I'd have to try to pull out some old stuff to try and make it 10.5 compatible.

    Is this a PPC Mac that can't go past 10.5? if so It won't run no matter what I do.

    With 10.8 coming out this month, you should really try to at least get to 10.6 but even support for that is starting to vanish... I'd get to 10.7 or 10.8 which is out soon.
     
  5. Chilaha, Jul 1, 2012
    Last edited: Jul 1, 2012

    Chilaha thread starter macrumors member

    Joined:
    Jun 26, 2011
    #5
    OK. Is there a way I can go straight to Lion instead of getting snow leopard? Sorry for the difficulties.
    Would it work on Ubuntu, I have a blank disc I can download that onto and put that on my mac.
     
  6. doh123 macrumors 65816

    Joined:
    Dec 28, 2009
    #6
    well when Mountain Lion (10.8) comes out this month its only $19.99, but they say it will only upgrade from 10.6 or 10.7... so I'd say if you can find a cheap legal copy of either one you should be fine if you want (and can on your Mac) do the upgrade to Mountain Lion in a few weeks.

    I do know that the normal 10.7 install is supposed to only be from 10.6, but I heard people upgraded it from 10.5 as well using the full upgrade version (has to update a lot other ilife apps that won't work and stuff).

    If you Mac is too low end, it might not be worth the hassle though.
     
  7. Chilaha thread starter macrumors member

    Joined:
    Jun 26, 2011
    #7
    OK. And, going back to Ubuntu/Linux, could I run the game through that?
     
  8. doh123 macrumors 65816

    Joined:
    Dec 28, 2009
    #8
    See if this one works in 10.5 .. I have no way to test it, but I think it should...

    https://dl.dropbox.com/u/4486028/Antagonist.app%20for%2010.5.zip

    ----------

    if you installed Wine you could get it to work through that in Linux I'm sure. It worked pretty easy in Wineskin on OSX, just one Direct3D registry change from normal.
     
  9. Chilaha thread starter macrumors member

    Joined:
    Jun 26, 2011
    #9
    It worked! Thanks. :)
     

Share This Page