Help please! Going mad after upgrading to Mac OS 10.6.8

Discussion in 'MacBook Pro' started by Chadster, Jan 26, 2015.

  1. Chadster macrumors newbie

    Joined:
    Jan 26, 2015
    #1
    I'm close to losing my mind. I bought a Snow Leopard disc to try and get things running better on my MacBookPro and it's pretty much done the opposite.

    I have a Lexmark X1130 all in one printer/scanner which now cannot be made to work. I've tried downloading the so-called latest drivers from both Lexmark and Apple...no joy. If anyone knows the magic way to sort this - please share it!

    I also upgraded my Google Chrome to the version for OS 10.6...only to find that apparently my Mac can't operate it. I've given up on that entirely and switched to Firefox but it's a right pain.

    As I wait to find out what else is going to go horribly wrong...feel free to warn me in advance!
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    The drivers for that model only go up to OS X 10.2.6. I'm assuming its an older AIO that Lexmark doesn't support. The date of those drivers is 2004. If the included OS X drivers (from Snow Leopard) are not supporting it, then you'll not get it to work.

    What's going on with Chrome, what issues are you running into that.

    What model MBP are you using?
     
  3. Chadster thread starter macrumors newbie

    Joined:
    Jan 26, 2015
    #3
    I'm far from tech savvy but the information I have about the model is this:
    Model Name: MacBook Pro
    Model Identifier: MacBookPro1,2
    Processor Name: Intel Core Duo
    Processor Speed: 2.16 GHz


    As for Chrome, with my new operating system I updated the version of Chrome which I allegedly could now have...but it can't even open. No idea why.

    Thank for the suggestion that my printer is now defunct.

    Anyone able to tell me how I can uninstall Snow Leopard and return to original factory settings? I have a strong feeling that will be preferable!
     
  4. Samuelsan2001 macrumors 603

    Joined:
    Oct 24, 2013
    #4
    To put it simply

    That laptop is 9 years old, snow leopard hasn't been supported for updates etc for at least 3 years and your printer is even older. Basically your tech is obsolete, can you get it all working?? probably with a lot of mucking about but it's not worth it. Is it time you invested in new equipment?? I'd say so.

    From the googled specs you have 1gb of RAM, unfortunately snow leopard really needs 2gb. You should probably just reinstall your original OSX from the disks (I'm assuming thats tiger) if you don't have them then you'll have to try and download a copy from somewhere and use diskmmaker X to make a usb iso disk to reinstall it.

    An upgrade to 2gb of ram may help you will need this

    http://eshop.macsales.com/item/Other World Computing/5300DDR2S1GB/

    To be honest that is getting towards a museum piece in computer terms....
     
  5. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #5
    You think that's a museum piece? The computer I'm using to post this right now is a 12" PowerBook G4 running Leopard on 768 MB.

    Anyway, going back to Tiger is not the solution as almost nothing is compatible with Intel Tiger nowadays.
     
  6. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #6
    Long story short, your devices are all too elderly and are no longer supported in this age.

    It's time you upgraded your devices even if they're still working. Those devices really belong to a museum.

    ----------

    Good old G4. I've got a 15" PB G4 double-layer SD from late-2005.

    It's still working fine to this day, and it's still running on Tiger (I always fire it up every now and then for the nostalgic feel of brushed metal UI).
     
  7. Chadster thread starter macrumors newbie

    Joined:
    Jan 26, 2015
    #7
    Thanks for the suggestions to buy new equipment. I don't have the funds for that. The simple fact is everything I needed was working fine until I installed Snow Leopard....more fool me!
     
  8. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #8
    Can you reinstall the older version of OSX that you were using?

    Being so old, you're better off staying with what works
     
  9. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #9
    OP:

    I'd suggest you delete all the "existing" printer drivers you're mucking with, and "start over fresh".

    Seems to me there are a few "generic" print drivers out there, that might be able to work?
    Could you try the Gimp-Print drivers:
    http://gimp-print.sourceforge.net/MacOSX.php

    There may be others as well.
    It may take some searching to find them.

    If nothing else works, you may have to consider upgrading the printer, which means "buy a new one". You can get Brother lasers for under $100 now, may even have wireless printing and ethernet connectivity as well as USB. Of course, these are B&W/greyscale only, don't do color, but at least they PRINT.

    Regarding OS 10.6.8 in general -- it has a solid reputation for being one of the most stable OS's that Apple released.
    There are always "bumps in the road" when moving from one OS to another. One just has to "work through" them as required.

    Regarding your problems with Chrome:
    There must be versions of Chrome that work with 10.6.8. I have never been a Chrome user because I didn't want all the Google tracking stuff.
    I have found an alternative browser which uses the Chrome "engine", but has all the google stuff "stripped out". It's called the "Epic Privacy Browser" and you can find it here:
    https://www.epicbrowser.com

    If you continue to have problems with Chrome, I suggest you visit the page above, and consider downloading Epic and give it a tryout.

    Addendum:
    Ah, I reread your original post and see it's a combo printer/scanner. Insofar as the "scanning" end goes, you might consider downloading something called "VueScan" to see if by chance that could work for the scanning portion of the printer...
     
  10. Chadster thread starter macrumors newbie

    Joined:
    Jan 26, 2015
    #10
    I just want to go back to what worked beforehand. I think my system was Leopard.

    I don't think I have discs for it.

    Anyone know how I can uninstall Snow Leopard and download Leopard?
     
  11. cairene2011 Guest

    Joined:
    Dec 17, 2013
    #11
    You could always bring it to an apple authoritized service provider. They might have the various OS at hand. That's probably better than messing around with it even more by yourself if you aren't sure about it. :)
     
  12. catzilla macrumors 6502

    catzilla

    Joined:
    Dec 15, 2013
    Location:
    Rhode Island
    #12
    Me too! But I upgraded to 1.25gb.
     

Share This Page