HELP PLEASE!!! Half of my screen has gone white!!!!!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by timberz, Jan 16, 2008.

  1. timberz macrumors newbie

    Joined:
    Dec 23, 2007
    #1
    Hi Everyone,

    I really hope somebody can help me with this. I have a US v1.1.2 iphone. Been working absolutley fine and then all of a sudden the bottom half of my screen has gone white. You can still kinda see some stuff under it and the top half is perfectly normal!

    ive tried turning it totally off then back on but its not helped.
    Not sure if I should do a restore then jailbreak and so on again.

    Does anybody have any kinda idea of whats going on?
    Please somebody have a solution.:(

    Many thanks in advance.
     
  2. PatrickC macrumors member

    Joined:
    Nov 2, 2007
    #2
    I would suggest doing a full restore, then set up as a new phone (your phone will still be set up for your #.) If the problem persists after this, take it into an Apple Store. But I'm sure someone more knowledgeable will chime in here.
     
  3. timberz thread starter macrumors newbie

    Joined:
    Dec 23, 2007
    #3
    Im scared to do a restore because im not sure if it updates to the most recent version at the same time.

    Can somebody more knowledgeable then me please confirm?
     
  4. blaster_boy macrumors 6502

    blaster_boy

    Joined:
    Jan 31, 2004
    Location:
    Belgium
    #4
    From the above I understand that you are running an unlocked and jailbroken iPhone ?

    Unless you upgraded your iTunes to the latest version available (7.6, released this week) you should be fine to do a restore to 1.1.2.

    If you have never done this before, then now is the time to start reading all the guides on modmyifone.com and other sites...

    Also, I don't like to be the bringer of bad news and I hope it's not true, but from what I read about broken iphones seems to indicate that the physical screen is in two part ? So this would mean that you don't have a software problem, but a hardware problem...:(
     
  5. ernesto99 macrumors newbie

    Joined:
    Jan 22, 2008
    #5
    exact same problem

    I have a US phone with 1.1.2 and have only just opened it out of the box to find it has exactly the same screen problem. I restored it and this had no effect at all.
     

Share This Page