Help Please Hard drive won't show Mac pro lost all my work

Discussion in 'Mac Pro' started by Zobec, Mar 30, 2015.

  1. Zobec macrumors member

    Joined:
    Dec 12, 2010
    #1
    Hi, I think i have lost all my work and I don't have a back up, I did not create any back ups. What can I do? I can't believe it, it was all okay yesterday. Now it is all gone

    I am running mac 10.8.5

    The hard drive was 2 tera bytes it had a partition of bootcamp 500gig on it. Perhaps the partition has messed up the mac drive some how

    Disk utility has changed the HD drive name to disk 3s2

    /dev/disk3s2 invalid BS_impBoot in boot block : 000000

    Error: Disk utility can't repair this disk. Back up as many of your files as
    possible, reformat the disk, and restore your back up files

    It won't allow me to back up my files, the hard drive does not show up HELP ME PLEASE.

    What are my options. I kind of live in the middle of nowhere there are no mac stores but I need to somehow recover my files please is this possible.
     
  2. 666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #2
  3. Zobec thread starter macrumors member

    Joined:
    Dec 12, 2010
    #3
    Oh Thank you 666sheep I can't tell you how much I am grateful. That is exactly what has happened.

    Lions "install or restore" utility and disk utility informed me the entire 2Tb of my OSX drive with all my life on it were now a virgin clean FAT partition. Any attempt of scanning or repairing that partition in Disk Utility would return error “invalid BS_jmpBoot in boot block: 000000″.

    It seems I can recover the drive but I don't think I can jump to everything is okay yet. I looked at the link seems complicated I have never done anything like that.

    I don't have 2 mac systems, I do have a 8GIG USB drive, I have a windows 7 laptop, can this still work? Something about needing Xcode. I would pay someone to help me recover my work from the hard drive. It has all my life from the past 4 years on it.

    I was going to go to the main city, where I live, I heard there is a apple store in the city but looking at this error I don't think they can fix it.

    If someone can help me recover my drive, my work, I would pay them for the help through paypal or something like that.

    I have now brought a back up 1T USB2 drive, if I can recover my work and fix the 2T HD drive that is where I will be putting the back up of my work.
     
  4. Zobec thread starter macrumors member

    Joined:
    Dec 12, 2010
    #4
    I also don't understand how a windows partition has affected the OSX partition, something about happens when Windows decide to, at any point, assign new or change a windows drive letter of your bootable system GPT partition.

    I wonder can I delete the windows partition and recover my work on the OSX side of the hard drive? The OSX has my work that is not backed up.

    What would be the best way if I don't have another OSX machine to follow the instructions.

    I can log into OSX still. As the OSX is in hard drive bay 1 the hard drive with problem “invalid BS_jmpBoot in boot block: 000000″. is in hard drive bay 2
     
  5. 666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #5
    If you have working OS X on your HDD in bay 1 then follow v0n's instructions: install Xcode, python etc. In v0n's post I linked you'll find a link to gpt_surgeon.py author's blog. There's some more info and video tutorial. Do not try to remove Win partition before you'll fix GPT one and retrieve (and backup) your data.
     
  6. dmylrea macrumors 68000

    dmylrea

    Joined:
    Sep 27, 2005
    #6
    (Deleted original post) I just reread your post that you had a bootcamp Windows partition on it. Was it an existing partition or did you just run the bootcamp wizard to set it up?
     
  7. Zobec thread starter macrumors member

    Joined:
    Dec 12, 2010
    #7
    I downloaded Xcode install ports, am I correct in believing that this is needed if I cannot access my OSX? I guess I am lucky that I can access my OSX so I guess this step is not needed or is?

    @dmylrea it was an existing partition that I have had for a while no problems with windows or mac OSX but reading through v0ns post my instance of bootcamp seems to have acted the same way as v0ns a few months back. My laptop which is windows, also acted this way near enough at the same time as my bootcamp problem. I had to reinstall windows on my laptop. I did not do that for bootcamp, though I guess i should of. Though this problem of my disappearing hard drive transformed to EFI has only happened a few hours ago, everything was fine, I was doing work yesterday everything was okay.

    Using diskutil list command in the terminal I could look at the drive the HFS type has changed to EFI it has changed to windows, how did windows do this? I don't understand how windows could change the whole drive like this.

    The disk I am looking for is disk2 under disk2s2 1.5TB

    Code:
    /dev/disk2
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      GUID_partition_scheme                        *2.0 TB     disk2
       1:                        EFI                         209.7 MB   disk2s1
       2:       Microsoft Basic Data                         1.5 TB     disk2s2
       3:       Microsoft Basic Data BOOTCAMP                500.1 GB   disk2s3
    
    I have tried to fix it using this code

    Code:
    Last login: Mon Mar 30 20:00:30 on ttys000
    :~ mithius$ cd Desktop/
    : Desktop mithius$ chmod +x gpt_surgeon.py
    : Desktop mithius$ ./gpt_surgeon.py list /dev/disk2
    
    Traceback (most recent call last):
      File "./gpt_surgeon.py", line 216, in <module>
        main()
      File "./gpt_surgeon.py", line 202, in main
        listGPT(diskDevice)
      File "./gpt_surgeon.py", line 140, in listGPT
        _, gpt = readMBRAndGPT(diskDevice)
      File "./gpt_surgeon.py", line 132, in readMBRAndGPT
        disk = open(diskDevice, 'rb')
    IOError: [Errno 13] Permission denied: '/dev/disk2'
    Desktop mithius$
    
    I seem to be getting permission denied error no13, it won't let me see any of the disks using the surgeon.py script but diskutil list works

    I don't know what error 13 is?

    looking at the video one needs to have super user permissions on, using sudo command in the terminal but it does not even list my drive through the surgeon.py script list so I have not tried that yet.

    https://www.youtube.com/watch?v=Xumbf5rOp6c


    It seems every turn foiled, I guess slowly working
    towards a goal but I still don't know if my data is there that is what is killing me.
     
  8. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #8
  9. Zobec thread starter macrumors member

    Joined:
    Dec 12, 2010
    #9
  10. netkas macrumors 65816

    Joined:
    Oct 2, 2007
    #10
    Dont do anything, just take out hdd and get it to some local data recovery firm. They will do it much better, will take some money, but it information there is important it will worth it.
     
  11. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #11
    Please hold for some GPT guru's to determine EXACTLY what is causing your problem before using ANY commands. I understand your hurry, but for now keep calm & rely on the correct help for your situation.

    Cheers
     
  12. theSeb macrumors 604

    theSeb

    Joined:
    Aug 10, 2010
    Location:
    Poole, England
    #12
    Seriously... do what this guy suggested.
     
  13. boast macrumors 65816

    boast

    Joined:
    Nov 12, 2007
    Location:
    Phoenix
  14. Zobec thread starter macrumors member

    Joined:
    Dec 12, 2010
    #14
    @m4v3r1ck Yes, I think I was using a mac drive within bootcamp, rarely used it. OSX and windows were not used for the same thing not sure why I even had mac drive in there. Do you believe that this could have caused the problem?

    I was going to try
    sudo ./gpt_surgeon.py repair / dev/disk2 2

    but I stopped I have not tried to fix it using sudo, sudo might make things worst but it might also repair the drive, lost at what to do. I don't even know if that python file is the correct file, it is not working correctly when it gives a error13 code

    theseb@ I am worried I can mess this all up. The only thing I have done so far in the terminal is look at diskutil list find the disk and tried to get the python surgeon script to list the disks but that failed with error no13.

    Netkas@ I took the hard drive out, went to a local CPU repair shop today but they said they could not help because I said it is in a Apple format, they only repair it seems window formatted drives but I realised that windows has changed the HFS of this drive to EFI, this happened so quick I still can't believe it, so now it seems this drive is windows formatted, even though it is not, I really am confused.

    I don't know of many or if any shops round here that deal in recovery in a small town in the middle of nowhere. There is an apple store in the city though, so they say. I don't think apple can help with this.

    The hard drive I believe works, then again I am not sure of anything anymore.

    If the only option is to go to a specialist in recovering hard drives I will try to find someone and see what can be done if anything.

    @m4v3r1ck thanks for the kind words, I am sorry if I am not clear, I'm kind of erratic at the moment. I never backed up the drive I never thought anything would happen to it and today I brought a 1TB usb back up drive it is probably too late.
     
  15. dmylrea, Mar 30, 2015
    Last edited: Mar 30, 2015

    dmylrea macrumors 68000

    dmylrea

    Joined:
    Sep 27, 2005
    #15
    Zobec, take a look at this post...it seems exactly like your problem, and a simple command is all that is needed to change the filesystem type label back to "Apple_HFS". The relevant stuff starts at the poster's step 9 (maybe a bit in step 5).

    I believe your command would be sudo asr adjust --target /dev/disk2s2 --settype "Apple_HFS"

    Some people have verified that it "saved their bacon" (which translates to it worked and saved their data).

    I know others here have said to wait and have a PRO try, but read the post and see if it is your problem and decide if you want to try it.

    All of this assumes, of course, that the data is still intact on the partition. If, on the other hand, it has been formatted, you will need professional data recovery.
     
  16. Zobec thread starter macrumors member

    Joined:
    Dec 12, 2010
    #16
    Yes!! you saved it

    dmylrea@I can't believe it you are amazing you saved the drive, the drive is back. I hope nothing but goodness, good fortune falls your way thank you so much I can't repeat that enough, thank you again.

    I never really used sudo before so I had to create a user login password as the admin. I was reading sudo in the terminal it requires a password by default a user password not a root password I am not sure what a root password is

    http://unix.stackexchange.com/questions/58705/mac-os-x-partition-type-problem

    this command saved me
    sudo asr adjust --target /dev/disk2s2 --settype "Apple_HFS


    The hard drive for some reason is now making search noises, as if it is in use, it is not in use, is that common for the drive to be like that? Is there a test to see if both the HFS and EFI parts of the disk are running okay? I used disk utility to verify disk and repair disk everything turned out green, though it is still making that seach noise and i have no idea why. A few months back bootcamp/windows I noticed that the hard drive would make small searching sounds constantly, yet the drive in OSX would never make any search sounds unless I was looking for a file.

    I am going to back it up right now. perhaps delete windows that might be a problem I don't know.
     
  17. dmylrea macrumors 68000

    dmylrea

    Joined:
    Sep 27, 2005
    #17
    Zobec, I am VERY HAPPY that it worked for you. Being in the IT business myself for over 20 years, I certainly have been in your situation and know very well how happy you feel now.

    Backup, backup, backup, my friend. Time Machine is easy, automatic and free. Use it. :)

    I don't know about the sound you are hearing. Hard drives do make noise from background tasks, so maybe some process is running in the background on the disk. Do a backup, and let some time go by and see of the sounds stop.

    Good luck!
     
  18. AidenShaw macrumors P6

    AidenShaw

    Joined:
    Feb 8, 2003
    Location:
    The Peninsula
    #18
    Perhaps Spotlight is indexing it?


    Backup first, before changing anything.
    __

    I'm happy for you that you got the help here that you needed, and had such a great outcome.

    One bit of earlier advice can't be stressed enough - don't write to the disk until you understand the actual problem completely.

    When I've hit situations like this, my first step is to boot into a Linux LiveCD (or thumb drive) and use "dd" to make a bit-for-bit copy of the drive - unaltered. Sometimes I've purchased a new drive for this "dd" copy - if the data (or the time to recreate it) is worth more than a bare drive, a no-brainer. It doesn't matter if you're on Linux/Windows/AppleOSX - a bit-for-bit copy of a harddrive is portable. (Tip: don't pipe "dd" to "gzip" - you'll turn a 2-hour IO problem into a 20-hour CPU problem.)

    Once I have a bit-for-bit backup, then I'll try the recovery tools. If they work - great. If they destroy the disk, I restore the bit-for-bit copy and try something else.
     
  19. Zobec thread starter macrumors member

    Joined:
    Dec 12, 2010
    #19
    Amazing, cheers, thanks so much.

    AidenShaw@

    I think you are right the hard drives have gone quiet again I hope it stays quiet upon next start up, this is great news. This is how the drive was before love it. It is has turned out okay oh man wow the stress of losing data is something I don't know how to explain. It was like one minute the drive was there and the next minute <bang> the drive has vanished so unexpected indeed.

    Thanks
    .

    Yes thanks, I am in the process of setting up time machine and hope that it all works out.

    I would like to thank everyone that helped and offered advice, truly am grateful cheers.
     
  20. troy14 macrumors 6502a

    Joined:
    Mar 25, 2008
    Location:
    Las Vegas (Summerlin), NV
    #20

    I viewed this thread when you had 0 replies and shamefully thought to myself "another one who realized that it is important to have backups, but just a little too late".

    I am very happy for you that you got lucky and were able to get your work back.

    Perhaps now it is important to looking into a real backup solution so you don't ever have to worry about losing all of your work or memories again? I think this would be motivation enough.
     
  21. Zobec thread starter macrumors member

    Joined:
    Dec 12, 2010
    #21
    Hi again I am in the process of backing up the files that I need on the USB2 hard drive using time machine.

    I have separate from time machine, the important files stored also on the same time machine hard drive. I think windows partition has become corrupted maybe a virus or something todo with updates. When I try to repair the disk it says updating boot support partitions for the volume as required Error:couldn't unmount disk

    I am not sure why I get this error, what would this error mean?

    Should I just delete and wipe the whole drive?
    Delete just the partition bootcamp?

    What would be the best way to delete bootcamp if it is corrupted?

    I have not gone into bootcamp in a while but there are some files that I need to get from bootcamp also, I am afraid that might make the situation worse.

    Time machine is taking a while.
     
  22. dmylrea macrumors 68000

    dmylrea

    Joined:
    Sep 27, 2005
    #22
    Can you not read the Windows partition from within OS X? You should be able to at least open the drive and copy files from the Windows partition. Windows is NTFS or exFAT, both of which are readable in OS X.
     
  23. Zobec thread starter macrumors member

    Joined:
    Dec 12, 2010
    #23
    I googled around and it seems that people have various methods for deleting bootcamp.

    One method was to use command-option-r and wipe the drive
    another method was to use bootcamp in OSX to delete the partitioned drive

    My OSX 10.8 is in drive bay1
    The windows partition is in drive bay2 separate drives, I guess never put 2 different OS's on the same drive, that would have been disaster, maybe there are instances or many instances when 2 OS's on the same drive is needed.

    I would also like to ask that the problem that seems to be affecting bootcamp, can this problem in drive 2 spread to other drives like drive bay1 with my OSX? I am not sure if corruption of data works like that.

    Thanks again, yeah I can see bootcamp I can see the files I need, I have another external hard drive 500G but it is formatted for windows NTFS, OSX can only read from the drive, that seems to be the only privilege I have with that drive. I can't seem to move folders from bootcamp to the external NTFS drive. However I think it will allow me to move bootcamp files to the OSX partition which I find strange.

    Time machine is in the process of backing up drivebay2 which is 2TB and the external drive I brought for time machine is only 1TB just large enough for time machine to make a back up, if I start putting files onto the drive in bay 2 (2TB drive) will that not change the size of drive in bay 2 and might make time machine say that the 1TB external drive is not large enough?

    I would really like to use the 500G external drive that is windows formatted for the files in bootcamp to keep everything separate.
     
  24. Demigod Mac macrumors 6502a

    Joined:
    Apr 25, 2008
    #24
    Generally, it takes sustained effort for the computer to truly delete data from a drive (have to write-over the data being erased) so if it's an issue with the filesystem the data's most likely still there and can be retrieved somehow. So rarely do you see a non-physical issue where a huge number of files are irretrievably lost in an instant. I wouldn't give up just yet.

    For backups check these guides:
    http://macperformanceguide.com/topics/topic-Backup.html
     
  25. dmylrea macrumors 68000

    dmylrea

    Joined:
    Sep 27, 2005
    #25
    If you can format the external drive in OSX as exFAT instead of NTFS, you can have full read/write access to the drive from both Windows and OS X. It is the one partition formatting scheme that both OS's share.

    ----------

    If you read all the posts, you will see that Zobec was able to fix the drive and recover his files.
     

Share This Page