Help Please: iMac Flash Problem

Discussion in 'macOS' started by topmounter, Apr 13, 2012.

  1. topmounter macrumors 68020

    topmounter

    Joined:
    Jun 18, 2009
    Location:
    FEMA Region VIII
    #1
    I've had this issue for a while, but it only occurs on my iMac and it only occurs on "some" Flash sites. It happens in both Safari and Chrome and has continued over multiple browser and Flash versions. I'm running the latest and greatest version of Lion (fully patched as of 4/13/12), but this has been occurring for quite a while through multiple versions of OSX, Flash, Chrome and Safari. I've also tried running "Repair Disk Permissions" and that doesn't fix the problem.

    When I check Adobe.com/software/flash/about in Safari, it tells me that I have "11.2.202.233" installed. When I check using Chrome, it tells me that I have "11.2.202.229" installed.

    Videos on Youtube, Mevio, Vimeo, DailyMotion and others play just fine.

    However sites like South Park Studios and Funny Or Die do not play and just show a black box where the video should be playing (the Flash banner ads display just fine).

    My MacBook Air is running all the same OS and software versions, but has not had any problems with these sites.

    Does anyone have any ideas on how I might fix this problem on my iMac?
     
  2. blatopilot macrumors regular

    Joined:
    Sep 24, 2011
    #2
    Do those sites use Silverlight?

    Chrome has flash built in by the way. Type "about:plugins" in your address bar.

    There will be two versions of flash there, you troubleshoot by disabling one or the other.
     
  3. topmounter thread starter macrumors 68020

    topmounter

    Joined:
    Jun 18, 2009
    Location:
    FEMA Region VIII
    #3
    I can't say I know how to tell whether they're using Silverlight or not.

    I've tried disabling one or the other Flash Player in Chrome, but it hasn't made a difference in the past (nor does it seem to now).

    However, if I disable BOTH of them, Funny or Die starts working, but South Park Studios doesn't... and it breaks Mevio, but not YouTube, Vimeo or Daily Motion.

    Regardless, disabling one or both players in Chrome doesn't do anything in Safari.

    Since Funny Or Die starts working when I disable both Flash plug-ins, I'd say there is some incompatibility between the site and the default player as it is installed or configured on my iMac...
     
  4. blatopilot macrumors regular

    Joined:
    Sep 24, 2011
  5. topmounter thread starter macrumors 68020

    topmounter

    Joined:
    Jun 18, 2009
    Location:
    FEMA Region VIII
    #5
    None of the previous Flash updates have helped... and the comments for that beta are not encouraging.
     

Share This Page