Help please..System Pref isn't working.

Discussion in 'Mac Basics and Help' started by copernicus, Sep 27, 2010.

  1. copernicus macrumors newbie

    Joined:
    Sep 27, 2010
    #1
    Im using an imac OS 10.5.8 When I click on system preferences it just gives a little blink but wont open, doesn't load from the icon in applications either. All I can think is that one of my kids may have trashed it but it's doubtful. What could have happened? Do I need to re-install OS? help please!!
     
  2. mulo macrumors 68020

    mulo

    Joined:
    Aug 22, 2010
    Location:
    Behind you
  3. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #3
    Is it also gone from the Applications folder or may it be in the Trash?

    Have you repaired permissions yet?

    Does the same problem occur in another account?
     
  4. copernicus thread starter macrumors newbie

    Joined:
    Sep 27, 2010
    #4
    Yes its in my application folder but like I said, It just wont open..zilch
     
  5. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #5
    When it is in the Applications folder, none of your kids has trashed it.

    What about that other account (create a temporary one if necessary) or the permissions repair?
     
  6. copernicus thread starter macrumors newbie

    Joined:
    Sep 27, 2010
  7. copernicus thread starter macrumors newbie

    Joined:
    Sep 27, 2010
  8. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #8
    Permissions Repair done yet?

    You can try deleting Macintosh HD / Users / YOU / Library / Preferences / com.apple.systempreferences.plist and see if that helps. The .plist file is the property list file and will be re-created upon opening the application.
    If that does still not work, get out the Restore DVD and use Pacifist to extract System Preferences from there.
    If that does still not work, a reinstallation might be in order, though someone might take a look at this thread and have a better idea.

    Btw, as this happens quite often, there are many threads touching this subject. Maybe have a look at them.
     
  9. copernicus thread starter macrumors newbie

    Joined:
    Sep 27, 2010
    #9
    Permissions repaired. I Clicked on system pref, the icon jumped up in the dock then disappeared again.. I'll try the install disk. Thanks.
     
  10. copernicus thread starter macrumors newbie

    Joined:
    Sep 27, 2010
    #11
    Nope, pacifist didn't do it. If I re-install the applications bundle from my original install disc

    1-will this include the system pref app?
    2-will my data eg photos etc be safe or do I need to back it all up on an external drive?
     
  11. pintsizemacman macrumors regular

    pintsizemacman

    Joined:
    Sep 26, 2010
    Location:
    ohio
    #12
    use ur install cd and do an optional install pick systm prefs an no your files should be safe but u can back um up if important
     

Share This Page