HELP please; upgrading memory

dmut

macrumors newbie
Original poster
Sep 28, 2006
11
0
I jsut bot 2 1GB chips to upgrade my 20" Intel Core Duo iMac. For some reason, when I go to About thie Mac, it is only showing 1 have 1GB of memory. I have tested both chips, and they are good. If I click on "memory" in the computer properties window, it says DIMM1/Bank1 1GB, but does not even list DIMM2/Bank2. Did I screw something up? Have a hardware problem?

Thanks!!
 

nagromme

macrumors G5
May 2, 2002
12,546
1,186
Try just one, then just the other... and try swapping them. Maybe that will pin down the problem. Also blow out the socket... dust maybe?
 

dberg

macrumors member
Jun 15, 2005
44
0
this guy is my buddy and I told him to post here for help.

He actually tried each 1Gb on its own in DIMM1 and it worked fine. However when 2 DIMMS are occupied, it only recognizes 1GB. Very odd.
 

nagromme

macrumors G5
May 2, 2002
12,546
1,186
Sounds like one slot may be bad :( Unless some kind of RAM failure occurs only with pairs? :confused:

If he puts the original 2x512 in, do both 512s show up?

What about if he puts in 1GB + 512?


scott523 said:
You should check if 1GB chips are properly seated. By the way, I thought iMacs can't be opened up?
They can be, but not easily and not supported by warranty... EXCEPT for RAM. RAM is very easy to get to: there's a hatch on the bottom edge, and you're allowed to use it :)