HELP!! Please....... (uploading images from camera, stuck)

Discussion in 'Mac Basics and Help' started by iMac751, Dec 13, 2009.

  1. iMac751 macrumors newbie

    Joined:
    Dec 13, 2009
    #1
    OK so I bought my mac back in August this year so I am still fairly new to the computer. About 2 1/2 to 3 weeks ago I plugged my camera in the import some photos (my wife has done this before with her camera and we have never had any problems like this before). So I plugged in my camera and it started to upload the pictures, well my camera decides to die. When it did that, a message came up on the screen saying that the device was improperly disconnected. So I plugged my camera into an outlet and plugged it back into the computer to upload the rest of the photos. Well ever since then, it has been stuck on the same picture it was uploading when my camera died and turned off. Now i cannot restart my computer, turn off my computer properly or even update my computer and restart it. I have tried plugging my camera back in several times to see if it would kicked it back up to load the photos but it is saying iphoto is still uploading my photos from the first time when it the camera died on me. Ive tried pressing the stop importing button and then the screen comes up and says "continue importing/delete photos/keep photos" and ive tried ALL three options and it still is stuck on the same screen. I CANNOT do anything to fix it. Any advise from anyone would be GREATLY appreciated.

    :confused:
    :mad:

    Thanks Again!
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Does Force Quit (CMD+OPTION/ALT+ESC) not work?

    What about a hard reset )holding the power button for six seconds)?

    If that works you can try repairing permissions via Disk Utility and see if that helped.
     

Share This Page