Help please with garageband.....

Discussion in 'Digital Audio' started by bingbong, Sep 26, 2009.

  1. bingbong macrumors newbie

    Sep 26, 2009
    i just bought a 'Prosound' mic to usb lead, plugged it into my mac and set it up in garageband. The mic was able to pic up sound and it showed in garageband but i couldn't hear anything out of my speakers. Why is this and how can i fix it?
  2. salientstimulus macrumors member

    Jul 3, 2009
    Is the problem that the microphone (only) doesn't play back during recording? Or that you have no audio output whatsoever while the microphone is plugged in?

    If it's the latter, check GarageBand>Preferences>Audio/MIDI Setup -- what does it say under input and output? GB might be trying to send your audio output to the microphone.

    If it's the former, make sure you have Monitor On (in the lower right panel of the 'real track' window). Be careful of feedback -- start with the volume low.
  3. GaragebandGuy macrumors newbie

    Sep 27, 2009
    I had a Prosound mic that exhibited the same behavior you described. I don;t think it was the mic at all because once I turned on the "Monitor ON" in the track window all was good and I could here the live input.
  4. 54321 macrumors newbie

    Sep 22, 2012
    Hi, I've bought the same lead as you, but i don't get any sound at all when plugging my regular mic in via the usb cable. I've tried going through preferences (in garageband) and making sure the monitor is on, and the microphone definitely is connected in properly, yet i get no sound at all even testing. When i go through system preferences and test, no sound is picked up either. Is there anything else i can do or do I need some sort of driver?

    Microphone is AKG D5 model, using a macbook air.

    It also says there are 0 MIDI connections in the preferences panel in garageband.
  5. fastlanephil macrumors 65816


    Nov 17, 2007
    I would try the Apple support site for GarageBand. Do a search for similar threads before posting your problem.
  6. ChrisA macrumors G4

    Jan 5, 2006
    Redondo Beach, California
    Have you turned on "monitoring" and is the track muted? I think this has nothing to do with the microphone

Share This Page