Help please

Discussion in 'iPhone Tips, Help and Troubleshooting' started by marzkid, Dec 15, 2008.

  1. marzkid macrumors newbie

    Joined:
    Dec 15, 2008
    #1
    My iPhone G3 arrived today, Great. However I own a G4 Powerbook OS X 10.3.9 and iTunes 7.
    When I connect the iPhone my iTunes doesn't engage with the phone.
    I've downloaded iTunes 7.7.1 but can't install it because its a exe file, what can I do?
     
  2. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #2
    Is it better than the G1? ;) JK

    The .exe means it is the windows version. You can download iTunes 8 here.
     
  3. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #3
    Did you even read the little notice before you made this thread or did you just laugh at it and put the title anyway?

    You can't use an iPhone with anything less than the latest version of 10.4.
     
  4. Me1000 macrumors 68000

    Me1000

    Joined:
    Jul 15, 2006
    #4
    even with the latest iTunes these are the System requirements for a Mac,

    http://www.apple.com/iphone/specs.html
     
  5. marzkid thread starter macrumors newbie

    Joined:
    Dec 15, 2008
    #5
    Thank you friendly Mac people and sorry for being so dumb!
     
  6. marzkid thread starter macrumors newbie

    Joined:
    Dec 15, 2008
    #6
    Ok, another simple question, how can I the install iTunes 7.7.1 I downloaded when its showing as an exe file?
     
  7. abijnk macrumors 68040

    abijnk

    Joined:
    Oct 15, 2007
    Location:
    Los Angeles, CA
    #7
    As was stated in the first reply, that is a windows executable. In other words, you can't.
     
  8. marzkid thread starter macrumors newbie

    Joined:
    Dec 15, 2008
    #8
    Thanks for letting me know again, as you can see I'm quick. Is it possible to download itunes 7.7.1? Maybe I'm a bit dumb but I've downloaded it 4 or 5 times (6 if I'm honest), and everytime its a exe file, maybe you could point me in the right direction?
     
  9. abijnk macrumors 68040

    abijnk

    Joined:
    Oct 15, 2007
    Location:
    Los Angeles, CA
    #9
    You could probably find it on file hippo or something. Just make sure you are getting the mac version. Your best bet really would be to just get the most recent version of iTunes. Care to tell me why you want that specific version?
     
  10. marzkid thread starter macrumors newbie

    Joined:
    Dec 15, 2008
    #10
    Yeah no problem.
    My iBook G4 is old and has OS X 10.3.9.
    Don't laugh.
    Thanks
     
  11. abijnk macrumors 68040

    abijnk

    Joined:
    Oct 15, 2007
    Location:
    Los Angeles, CA
    #11
    Oh, ok, I missed that. Well, as someone pointed out you might still have issues. The iPhone technical specs specifically say 10.4.10 or later. Good luck.
     

Share This Page