HELP!!! Please?

Discussion in 'Macintosh Computers' started by Bateman81, Apr 6, 2004.

  1. Bateman81 macrumors newbie

    Apr 6, 2004
    /me screams

    Okay. I need help. Have a friend who has a Powerbook running OS X. (Im a PC Person, always have been, so I know nothing about them!) Been working fine at hotels he has stayed at all around the country.

    He is up a hotel now and can not connect. I can take my Windows XP laptop and connect just fine. He can not retrive an IP Address.

    Everything is set right that I know of. Upon boot up it seems to take forever during the Network Initialization (well 15 sec or so).

    He obtains an automatic private address when the cable is plugged in. Without the cable..he has no IP address. I plug into the same jack, I get my address within 2 secs or so.

    This is a T1 connection through a Netgear 24 port switch (unmanaged). Anyone have some help for a guy??


  2. tdhurst macrumors 601


    Dec 27, 2003
    Phoenix, AZ

    So how is he connecting? Wirelessly? If so, go to sys prefs, network and then network port configurations under show near the top. Make sure airport is checked.
  3. Bateman81 thread starter macrumors newbie

    Apr 6, 2004
    Nope plugging in via Ethernet cable.

    I have gone in and unchecked On-board Ethernet

    Saved and Exit

    Gone back in and checked it again save again (What was recommended to me)

    Still no luck. Ideas anyone?
  4. jxyama macrumors 68040


    Apr 3, 2003
    could be the netgear switch... my friend's cable modem had a problem and i've had problems connecting my PB to a cable modem. even set to dhcp, somehow, the router remembered and refused to connect anything but windows machines. dunno why. in my friend's case, she upgraded from 98 to xp - and the cable modem wouldn't connect anything but the old 98.

  5. OnceUGoMac macrumors 6502a


    Mar 3, 2004
    It seems nobody ever reads carefully...

    He's not trying to connect to a cable modem, it's a T1 jack in the wall. I used to have this problem occasionally at school. From what I recall, I had to manually remove all previous setting under network. Hope that helps a bit. It may just be the hotel, who knows.
  6. stoid macrumors 601


    Feb 17, 2002
    So long, and thanks for all the fish!
    Sounds familiar, I had the same problem with our college's campus wide network. I don't remember doing anything to fix it, it just suddenly worked one day. Sorry this doesn't help you though very much. Although I think that at some point I even did a fresh OS install and it still didn't work, so I figured it was a campus network issue and not me.
  7. jxyama macrumors 68040


    Apr 3, 2003
    i know what he was saying, i know he wasn't connecting to a cable modem. i guess i should have clarified that if it's not as simple as plug and play for a Mac (for XP even, for that matter), the source of the problem could be anything. that's all i wanted to say.

    sorry if i sounded like i wasn't paying attention.
  8. laserbeahm macrumors member

    Feb 4, 2004
    Central Valley, CA
    Make sure that if he is connecting via Ethernet that his AirPort card is turned off. I took my iBook to a friend's house and connected to the Internet via Ethernet on his PC network. It should just work automatically.
  9. MrSugar macrumors 6502a


    Jul 28, 2003
    use the release / renew function under network in sys prefs. If it is still coming up with a yellow dot instead of green meaning, internal IP, double check and make sure air port is truned off... then perhaps try another room or another port to see if you get any difference. If not see if you can specify an IP.

    That's all I can think of :/
  10. Krizoitz macrumors 65816


    Apr 26, 2003
    Tokyo, Japan
    T1 lines still use a switch, and I've had the same problem in the past myself. Turned out that someone was running a server on the network I was on, that was confusing some of the Mac's and PC's into thinking it was a DHCP server (has to do with how the networking works, etc etc). The simple work around is to grab an IP address from your PC, plug it manually into the Mac, and plug the mac into the network and unplug the PC. As long as you stay connected you should be fine. Its a temporary fix at best.
  11. jeremy.king macrumors 603


    Jul 23, 2002
    Fuquay Varina, NC
    Obvious question = Are you sure the ethernet connection is configured to use DHCP?
  12. cebritt macrumors member

    May 1, 2003
    Austin, TX
    Try Using BootP

    I remember having problems years ago with Macs running System 8 logging into an NT server. The fix back then was to use BootP instead of DHCP.

    Another thought is that if it's an intranet,, you could just manually enter IP numbers until you get one that works.

Share This Page