HELP plz! Using Safari, when I enter a term in the search bar, it has begun

Discussion in 'Mac Apps and Mac App Store' started by Salemite, Oct 21, 2013.

  1. Salemite macrumors newbie

    Joined:
    Oct 21, 2013
    #1
    always to search in Bing rather than Google. I did not (knowingly) initiate any such change. I'd like to restore the search to Google, but can't.

    I've gone into Safari > Preferences > General, and changed the default search engine and default home page to Google.com, which is my preferred.

    BTW: Macbook Pro. OS X 10.7.5, Safari 6.0.5

    One further note (and I suspect somewhere in here may be the culprit), just before the aforementioned and inexplicable switch to Bing in my search bar, I downloaded a free (brushstroke) font from a site now lost to me. I've searched both history and my downloads and cannot find the website or the download. Odd.

    Also about the same time this happened, I downloaded Firefox. Oddly (to me), Firefox has shown up corrupt, and cannot be opened or removed. When I try to remove it, I get this message: "The operation can’t be completed because the item 'Firefox' is in use." A glance at Force Quit shows no Mozilla or Firefox app open. When I try to open it, I get this message: "You cannot open the application because it may be damaged or incomplete." So I can't remove it because it is open; I can't open it because it is corrupt, and it doesn't appear in Force Quit.

    I am not sure if either the Firefox or the font downloads are related to my Bing issue.

    Any suggestions how I can stop this automatic use of Bing as search engine via my Safari search bar? Or, how to fix/remove Firefox?

    Thanks in advance! And if I posted this in the wrong place, please point out my error and redirect me. Thx.
     
  2. Stewart21 macrumors regular

    Joined:
    Dec 9, 2011
    Location:
    South Yorkshire
    #2
    Have you tried to CTRL Click the Firerfox icon and Chosen Quit from the pop up menu?
     
  3. Salemite thread starter macrumors newbie

    Joined:
    Oct 21, 2013
    #3
    Thx for the reply. The firefox icon doesn't appear anywhere other than in my Applications, but it shows itself corrupted there.
     
  4. smirking macrumors 6502a

    Joined:
    Aug 31, 2003
    Location:
    Silicon Valley
    #4
    I believe I ran into the same issue with Firefox before. I can't recall exactly how I developed the problem, but I used to have multiple editions of Firefox installed in my Applications folder and at some point I couldn't launch any of them anymore. I got the message Firefox was in use if I tried to launch any of them.

    I deleted them all and redownloaded a fresh copy of Firefox and that fixed it.

    As for your Bing problem, that's just weird. Changing your settings in Safari Preferences should have taken care of that.
     
  5. badams002 macrumors member

    Joined:
    Mar 28, 2013
    Location:
    TX
    #5
    Check to see if you unknowingly downloaded some Safari extensions. Chrome did that to me and actually put an extension that changed my homepage in Safari to Google.
     

Share This Page