Help! Power Button not responsive (maybe software?)

Discussion in 'OS X Mavericks (10.9)' started by LordMelkor, Jan 20, 2014.

  1. LordMelkor macrumors newbie

    Joined:
    Aug 6, 2008
    #1
    Recently, I've found that my power button on my 13-inch, Mid 2011 Macbook Air, is completely non-functional. Everything else operates as expected. I can even restart my computer from the apple menu (can't shut down because then it doesn't turn back on).

    The reason I'm not posting this in the hardware section, is that when I took it to the apple store, they popped my battery to do a hard SMC reset, and then my power button worked just fine. However, after I shut down again, the power button stopped working.

    Does anyone have any theories on what's going on?

    Note: I was using an open source binary that restored pre-maverick power button behavior, however the problem persists even after deleting that program and restarting. https://github.com/binchewer/power_fixer
     
  2. allthingsapple macrumors member

    Joined:
    Dec 27, 2013
    #2
    Firstly how are you removing the said program from your mac. Are you just dragging it straight to the trash? I'd either use the Sudo-rm terminal command or use can app such as app cleaner to remove the said app and all associated files, stopping it from reappearing on booting from cold or a restart. You've mentioned that you've tried a SMC reset, but have you tried a Pram reset?
     
  3. LordMelkor, Jan 22, 2014
    Last edited: Jan 22, 2014

    LordMelkor thread starter macrumors newbie

    Joined:
    Aug 6, 2008
    #3
    I did sudo rm to remove it. (It wasn't really an app per se. Was a binary I had to compile from source, and drop into /usr/bin)

    Just did a pram reset--no dice. :/
     

Share This Page