Help, Powerbook completely irresponsive

Discussion in 'Macintosh Computers' started by Googol, Sep 14, 2005.

  1. Googol macrumors newbie

    Sep 14, 2005
    My G4 powerbook is utterly dead.
    It refuses to start up.

    The power supply connector is glowing up red!

    I already tried:
    - new, full battery
    - another power supply
    - pressing power button for seconds
    - reset PMU, Power Management Unit:

    I'm desperate.
  2. wordmunger macrumors 603


    Sep 3, 2003
    North Carolina
    Make sure your battery is properly seated in the computer. You may want to clean the battery contacts. Then try holding down the power key for a few seconds. If that's not it, I can't help you.
  3. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Glowing red? Not orange? :confused:

    What was it last doing before it died on you? Is it possible a power surge wrecked the internals?
  4. Googol thread starter macrumors newbie

    Sep 14, 2005
    Yes, it is glowing orange, I'm colorblind.

    My Powerbook worked normally the last time.
    But then I didn't use it for about 6 months.

    Could some internal battery or so have run out? :confused:
  5. Passante macrumors 6502a


    Apr 16, 2004
    on the sofa
    I think your charger is fried

    Try this
    Check if your battery needs to be recharged. Press the small button on the battery.
    You should see one to four lights indicating the battery’s level of charge. If only one
    battery level indicator light is flashing, allow the power adapter to charge the battery
    until at least one indicator light is glowing continuously.
    If that does not work, return to the computer’s factory settings by disconnecting the
    power adapter, removing the battery, and holding down the power button for at
    least 5 seconds.

Share This Page